Connector routing regression due to geometry code changes

Bug #666586 reported by Michael Wybrow on 2010-10-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Michael Wybrow

Bug Description

This regression causes incorrect connector routing, due to incorrect convex hull points being passed to libavioid. The regression was presumably caused by changes to Inkscape's underlying geometry code (perhaps moving to 2geom).

This bug was reported to me via email by Tavmjong Bah, who included attachments showing the old (desired) result, the current result, and an SVG testcase which can just be opened in Inkscape to see the result.

I haven't confirmed that this problem effects the 0.48.1 branch (I'm currently waiting for it to clone from lp), but I assume it does since Tav asked me to fix it for the 0.48.1 release.

Michael Wybrow (mjwybrow) wrote :
Michael Wybrow (mjwybrow) wrote :
Michael Wybrow (mjwybrow) wrote :
Michael Wybrow (mjwybrow) wrote :

Fix committed in revision 9854 of the trunk.

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

Testing with Inkscape 0.48+devel r9854 on OS X 10.5.8 (default preferences):

Opening the file in a new window (i.e. Inkscape launched with the file name as argument, or from within Inkscape, if the current document is dirty and Inkscape opens a new document window) renders as expected with correct routing of the connectors in r9854.

I still see an issue with incorrect rendering if the file is opened from within Inkscape (so that the current document window and its controls are reused): some connectors are wrong, some are missing (looks the same on-canvas as in the preview of the file dialog).

Steps to reproduce:
1) open a new document in Inkscape
2) open 'Diagram.svg' from 'File > Open recent' or via file chooser
-> connectors still wrong

Workaround: e.g. toggle the visibility of 'Layer 1' (in r9853 this resulted in the same incorrect rendering as attached in comment #3; in r9854 the routing is correct like in comment #2).

Other unexpected behavior: if the initial rendering is wrong, drawing e.g. a new line changes the routing of the connectors (still wrong: object avoidance is ignored), undoing the last step deletes the line and changes the rendering of the connectors again: routing now is as expected.

Possibly related to bug #510618 “Closing unchanged SVG asks for saving” (<https://bugs.launchpad.net/inkscape/+bug/510618>) because it appears to depend on how the window is initialized in which the file with connectors between groups is rendered.

There are other issues reported with connectors connecting (transformed) groups.

su_v (suv-lp) wrote :

Issue as described in comment #4 still present in r9991 (bug #552289 and bug #510618 are fixed)

su_v (suv-lp) wrote :

Other routing regressions (tested with r10005) in initial (i.e. on load) routing of connectors between groups or across layers:

Bug #556467 “connectors between groups misplaced (regression)”
Bug #702234 “Incorrect routing of multi-layer connectors on load”

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers