Inkscape: A Vector Drawing Tool

Drag-Drop in XML editor sometimes fail

Reported by Jacques S on 2010-10-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

In XML editor, using drag-drop to move an element from one group to another group fail after two or more similar operations: the drag-drop is applied to an element which is not the element selected.

Workaround: wait a rather long time, then the drag-drop operates as wanted for few operations and failed again after.
Workaround(bis): close the file and open again.

Version: Inkscape 0.47, Windows XP sp2

Context: the svg file is a medium size file 120 KB, containing a collection of icons drawing. The structure is simple; it is a list of group with one path per group, but not arranged in logical order. I create new groups (one per icon drawing) and use the XML editor to move each group/path belonging to an icon to the corresponding new group.
Apparently, the software does not update immediately the pointers between internals structures, and after few operations, the drag-drop is applied to an element which is not the the element selected. However, the selection marker on the drawing page is always correct.

~suv (suv-lp) wrote :

possibly related to or duplicate of:
Bug #501237 “Rearranging XML nodes does not work correctly when changing hierarchy”
<https://bugs.launchpad.net/inkscape/+bug/501237>

tags: added: ui xmleditor
Jacques S (jacques-sevenet) wrote :

I agree
my report is apparently the same problem as described by ~suv in bug 501237

~suv (suv-lp) wrote :

Linking as duplicate to bug 501237. Please add a comment here and revert the duplicate status if you don't agree and think these are different issues which should be tracked separately.

I have the same problem.

Drag of XML nodes in XML Editor moves the wrong nodes after some editing.

The best workaround I know is close and reopen the XML Editor window.

I think the other bug report (501237) shoudl be have marked as duplicate of this report, as the other mentions other issues wich aren't realli bugs (SVG Renring order)

I have seen this bug on Fedora 20 and Ubuntu 13.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers