Extension 'Modify Path->Envelope' fails inside transformed groups

Bug #663667 reported by Kent Williams on 2010-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

I have some text that has been converted to a path. I wish to use the Modify Path->Envelope to change the envelope of the letters individually. When the extension is applied, the path is applied incorrectly.

Steps:
Type text, convert to path, break apart, ungroup. Draw a rectangle around a letter, convert to path, modify rectangle to trapezoid. Select text, shift-click select the trapezoid. Apply the extension Modify Path->Envelope. The path is modified very incorrectly.

I have attached a screen capture to illustrate. The letter A (which is a path) was modified with the extension, with the small, trapezoid with the thicker black outline. The thinner black line with a curve is serving as a guide.

If I leave the entire word as a group after converting from text to path and then apply the extension using the single letter's trapezoid, then the entire word is modified correctly into the trapezoid. This is not the behavior I'm seeking. If I apply the extension to the entire word (as a grouped path) with my curved guide shape, the extension completes, but the entire word path disappears.

In any case, it is not behaving at all as it is supposed to.

I am using Windows 7 64-bit, with Inkscape 0.48.

Kent Williams (williamskg6) wrote :
su_v (suv-lp) wrote :

> Select text, shift-click select the trapezoid.
> Apply the extension Modify Path->Envelope.
> The path is modified very incorrectly.

Please attach the SVG file used for the screenshot for further investigation.
Did you resize the page?

Possibly related to:
Bug #253296 “Perspective effect wrong when drawing size changed”
Bug #168942 “perspective extension fails on group with transforms”

tags: added: extensions-plugins
su_v (suv-lp) wrote :

In parts reproduced with Inkscape 0.48 and 0.48+devel r9837 on OS X 10.5.8

1) 663667-arched-text-1.svg
Document has not 'transform' attribute on the layer with the paths to be transformed:
-> extension works as expected.

2) 663667-arched-text-2.svg
After resizing the page vertically (which moves the entire top-level layer group(s) by adding a 'translate' attribute):
-> the next transformed path ('H') is displaced (offset related to the 'translate' attribute).

Duplicate of bug #253296 “Perspective effect wrong when drawing size changed”?
<https://bugs.launchpad.net/inkscape/+bug/253296>

su_v (suv-lp) wrote :

I'm sorry, but I didn't keep the file. I did resize the page after I created it
from the default to US Letter, landscape orientation.

I have created a new file and attempted exactly the same operations. I did not
resize the page, nor did I change its orientation. The exact same methods on
this new, non-resized page work as expected, so it would appear that the problem
is related to the drawing size change.

Thanks for the prompt reply.

-Kenton W.

________________________________
From: ~suv <email address hidden>
To: <email address hidden>
Sent: Tue, October 19, 2010 10:58:28 PM
Subject: [Bug 663667] Re: Extension Modify Path->Envelope is not working
properly

> Select text, shift-click select the trapezoid.
> Apply the extension Modify Path->Envelope.
> The path is modified very incorrectly.

Please attach the SVG file used for the screenshot for further investigation.
Did you resize the page?

Possibly related to:
Bug #253296 “Perspective effect wrong when drawing size changed”
Bug #168942 “perspective extension fails on group with transforms”

** Tags added: extensions-plugins

--
Extension Modify Path->Envelope is not working properly
https://bugs.launchpad.net/bugs/663667
You received this bug notification because you are a direct subscriber
of the bug.

Status in Inkscape: A Vector Drawing Tool: New

Bug description:
I have some text that has been converted to a path. I wish to use the Modify
Path->Envelope to change the envelope of the letters individually. When the
extension is applied, the path is applied incorrectly.

Steps:
Type text, convert to path, break apart, ungroup. Draw a rectangle around a
letter, convert to path, modify rectangle to trapezoid. Select text,
shift-click select the trapezoid. Apply the extension Modify Path->Envelope.
The path is modified very incorrectly.

I have attached a screen capture to illustrate. The letter A (which is a path)
was modified with the extension, with the small, trapezoid with the thicker
black outline. The thinner black line with a curve is serving as a guide.

If I leave the entire word as a group after converting from text to path and
then apply the extension using the single letter's trapezoid, then the entire
word is modified correctly into the trapezoid. This is not the behavior I'm
seeking. If I apply the extension to the entire word (as a grouped path) with
my curved guide shape, the extension completes, but the entire word path
disappears.

In any case, it is not behaving at all as it is supposed to.

I am using Windows 7 64-bit, with Inkscape 0.48.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/inkscape/+bug/663667/+subscribe

confirmed with Inkscape 0.48. attached is the original drawing with some text converted to path, and a polygon box.

Alvin Penner (apenner) wrote :

- then reload the original
- apply envelope extension
- result is as expected

Alvin Penner (apenner) wrote :

- then reload the original
- change document size from A4 to US Letter
- apply envelope extension
- result is unexpected

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2010-10-21
Changed in inkscape:
importance: Undecided → Medium
tags: added: transformations
summary: - Extension Modify Path->Envelope is not working properly
+ Extension 'Modify Path->Envelope' fails inside transformed groups
Alvin Penner (apenner) wrote :

attached is a new version of summersnight.py, which is used for the Envelope extension. This version will take account of transform elements that are present in either the source or the target.

- as usual, any testing would be welcome. If this works, I'll look at 'Perspective' as well.

Alvin Penner (apenner) wrote :

committed to bzr rev 10415

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2011-07-05
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
milestone: none → 0.49
su_v (suv-lp) wrote :

@Alvin - could this backported to 0.48.x by copy&pasting the function 'invertTransform()' from voronoi2svg.py (which is new file only available in trunk) [1] into 'summersnight.py ', and adding the changes to simpletransforms.py from r10414 [2]?
Or there other underlying changes in shared extensions files the fix depends on?

[1] <http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/view/head:/share/extensions/voronoi2svg.py#L168>
[2] <http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/10414#share/extensions/simpletransform.py>

su_v (suv-lp) wrote :

See latest comments in bug #168942 about back-porting to 0.48.x.

tags: added: backport-proposed
Krzysztof Kosinski (tweenk) wrote :

Backported to stable in 9862

Changed in inkscape:
milestone: 0.49 → 0.48.3
tags: removed: backport-proposed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers