opacity is not pasted with «paste the style»

Bug #660512 reported by Aurèle Duda on 2010-10-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

On Inkscape 0.48+devel r9749 custom (last bzr checkout), ubuntu64 10.10

When I copy an object with opacity<1, then I paste the style on a second object which has a different opacity, the opacity of the second doesn't take the value of the first.
If both objects have opacity != 1 or the first have opacity ==1 and the second opacity<1, it works (second object takes opacity value from the first).

description: updated
summary: - opacity is not paste whit «paste the style»
+ opacity is not pasted with «paste the style»
jazzynico (jazzynico) on 2010-10-14
tags: added: clipboard
jazzynico (jazzynico) wrote :

Reproduced on Vista, Inkscape 0.47 and 0.48.
If the source object has an opacity (opacity attribute, works as expected with alpha channel) of 1 and the destination an opacity <1, then the opacity is not pasted (color is correctly pasted).

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Gautam Goel (gautamasgoel) wrote :

I am working on Ubuntu and there is no such bug.
I think this bug should be labelled as being resolved.

su_v (suv-lp) wrote :

> I am working on Ubuntu (…)

Nice to know that you work on Ubuntu - relevant information however would be which version of Inkscape you use.

> (…) and there is no such bug

The bug as reported and confirmed in comment #1 still exists in Inkscape 0.48.2, 0.48.3.1 and current trunk (r11138): the object opacity of the source object does not override/reset a reduced opacity setting of the target object. AFAICT it does not depend on the OS/platform Inkscape is running on.

Beluga (buovjaga) wrote :

Could not reproduce. Plz re-test.

Per the description, I take the non-working situation to be:
1. Copy an object with opacity smaller than 100%
2. Paste style (ctrl-shift-v) to an object with opacity exactly 100%

This is contrary to jazzynico's comment #1, but I cannot reproduce any scenario I tried.

Win 7 64-bit
Inkscape 0.92pre1_64bit r15044

jazzynico (jazzynico) wrote :

Bug reproduced on Windows XP (32-bit), Inkscape 0.48.5.
Not reproduced with 0.91 (tested with different source and destination opacity settings).

Changed in inkscape:
milestone: none → 0.91
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers