Fields in Transform dialog reset

Bug #635521 reported by Bram Wayman on 2010-09-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

When selecting or deselecting "Relative move," the unit field resets to px. This shouldn't happen. Thanks!

Bram Wayman (bram-wayman) wrote :

Whoops, forgot to include system information. I know better than that, sorry. Windows XP SP2, Inkscape 0.48.

su_v (suv-lp) on 2010-09-11
tags: added: transformations ui
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48 and 0.48+devel r9755 on OS X 10.5.8

The unit selector also switches back to 'px' after pressing 'Apply' for an absolute move in custom units (e.g. mm), even in a new document with default units 'mm'.

Additionally, the units selector in the 'Transform' dialog ('Move' tab) ignores the default units as set in 'Document Properties' and always defaults to 'px'.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
jazzynico (jazzynico) on 2010-09-22
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

> Additionally, the units selector in the 'Transform' dialog ('Move' tab) ignores the default units as set in 'Document Properties' and always defaults to 'px'.

Should it be considered as a wishlist (and implemented in 0.49) or as a bug (0.48.1)?...

jazzynico (jazzynico) wrote :

Patch tested successfully on Ubuntu 10.04 and Windows XP, Inkscape trunk rev. 9775.
Please confirm!

Note that the default set to document unit only works when the svg file is loaded directly, but not when opened from a blank Inkscape instance (but AFAIK, this is a common behavior for all document unit initializations).

Bram Wayman (bram-wayman) wrote :

I would consider it a bug, as it has tripped me up several times. Unsuspecting users, expecting normal functionality, will not expect their input to get altered from what they intended by simply working through the dialog's options, especially in order.

(In general, with cases like this, I figure that if the program is acting unexpectedly, with negative results that "shouldn't happen that way," it's a bug. Wished-for features make users smile, not frown.)

su_v (suv-lp) wrote :

> the default set to document unit only works when the
> svg file is loaded directly (…)

> (but AFAIK, this is a common behavior for all document
> unit initializations).

Tracked in bug #362995 “Default Units in Document Properties ignored”

su_v (suv-lp) wrote :

Testing patch with Inkscape 0.48+devel r9777 on OS X 10.5.8

Fixes both (no regressions noticed ;) ):
- reverting to 'px' when changing relative mode or applying the transform
- default units are used when the document is opened in a new window (instead of reusing the current window, unchanged and new from template)

@JazzyNico - with regard to updating the units selector when changing the default units (or opening the document with custom units in the same window) - Craig Marshall (author of the 'Guillotine' extension) started to work on a patch for bug #362995. The initial version he gave me to test works fine for the selectors on the toolbar as soon as the units are changed in the document properties. I'll try to contact him if it would be fine to use it... haven't heard from him in a while).

I have just added a patch to bug #362995 which might help with this problem.

jazzynico (jazzynico) wrote :

Thanks Craig

jazzynico (jazzynico) wrote :

Fix committed in the trunk (revision 9777) and the 0.48.x branch (revision 9670).

Changed in inkscape:
milestone: 0.49 → 0.48.1
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers