Inkscape crashes (C++ Runtime Library) when using extensions

Bug #631281 reported by Dana Atchley on 2010-09-06
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

Using version 0.48 (also happened with 0.47) running on Vista Home Premium, 64-bit version, factory installed on an HP notebook.

This occurs with a number of the extensions when I attempt to apply them or even to obtain a preview of them. A dialogue window will pop up stating that the application had attempted to terminate in an unusual manner. The OS then runs the "I'm telling Mommy" dialogue (i.e., "Windows is looking for a solution") and when that's done presents a dialogue for closing the program. I attempted to use different extensions, but seem to get the same type of crash (my subjective experience).

Just to test, I ran Inkscape 0.48 again, and did the following:

1) created a rectangle shape using the rectangle tool;
2) selected the rectangle and coverted to a path using Obect to Path;
3) selected the whole path again; and
4) Went to apply the "Extrude" extension to the rectangle path.

The results were as follows:

1) the Inkscape dialogue came up saying that I needed to select two paths;

2) I clicked "Ok" on that dialogue;

3) the screen "blinked" quickly, the standard extrude dialogue box got and lost focus several times (the color of the border went off and on in the "active" color several times;

4) The OS kicks out a dialogue with the title "Microsoft Visual C++ Runtime Library" and contains the following content:

 "This application has requested the Runtime to terminate in an unusual manner.
Please contact the application's support team for more information."

(clearly, one of Microsoft's more informative and helpful crash messages, no?);

5) When I click "Ok" on that dialogue box, I then get another dialogue box that has this content (I redacted my actual username and replaced it with "MYUSERNAME"):

"Inkscape encountered an internal error and will close now.
Automatic backups of unsaved documents were done to the following locations:
        C:\Users\MYUSERNAME\New document 1.2010_09_05_23_52_18.0.svg"; and

6) Windows pops up the "I'm telling mommie" dialogue (i.e., "Windows is looking for a solution..."), doesn't find a solution, and then says that Windows will close the program and notify me if a solution is available. When I click "ok" on that dialogue window, Inkscape closes out.

I've gotten three crashes like this tonight, each time attempting to use a different extension. The event viewer data on the crashes is as follows:

Crash 1
----------------------------------------------------
Faulting application inkscape.exe, version 0.47.0.9, time stamp 0x4c691d0c, faulting module libglib-2.0-0.dll, version 2.22.3.0, time stamp 0x4b1e650e, exception code 0x40000015, fault offset 0x00050083, process id 0x109c, application start time 0x01cb4d6cf2c9af33.

---------------------------------------------------

Crash 2
---------------------------------------------------
Faulting application inkscape.exe, version 0.47.0.9, time stamp 0x4c691d0c, faulting module libglib-2.0-0.dll, version 2.22.3.0, time stamp 0x4b1e650e, exception code 0x40000015, fault offset 0x00050083, process id 0x448, application start time 0x01cb4d7147c00853.

---------------------------------------------------

Crash 3
---------------------------------------------------
Faulting application inkscape.exe, version 0.47.0.9, time stamp 0x4c691d0c, faulting module libglib-2.0-0.dll, version 2.22.3.0, time stamp 0x4b1e650e, exception code 0x40000015, fault offset 0x00050083, process id 0xdb4, application start time 0x01cb4d759d7da913.

Unfortunately, the exception code 0x40000015 is probably not very helpful as it appears to refer to this error: 'STATUS_FATAL_APP_EXIT ("Fatal Application Exit")' - which was pretty self-evident all by itself.

At any rate, I hope that either I'm just missing an easy fix/work-around, or that this info helps to pinpoint what's going on; given how frequently the error occurs, it really puts a drag on using Inkscape.

su_v (suv-lp) on 2010-09-06
tags: added: crash extensions-plugins win32
Changed in inkscape:
importance: Undecided → High
jazzynico (jazzynico) wrote :

Not reproduced on Windows XP (32bits) and Inkscape 0.48.
Maybe a Vista/Seven or 64bits specific issue.

Dana Atchley (dana-atchley) wrote :

Could it have anything to do with the fact that the 64-bit version of Vista has two locations for program files, the first, "C:\Program Files", is for 64-bit programs, and 32-bit programs are placed into a new directory called "C:\Program Files (x86)"? Is it possible that something has been hard-coded to look for 32-bit files in a directory named "C:\Program Files" (I believe that that is what the program files directory is called on the 32-bit versions of Windows).

Confirmed by duplicate bug #888465.

summary: - 0.48 on Vista x64 crashes when using extensions
+ 0.48 crashes (C++ Runtime Library) when using extensions
Changed in inkscape:
status: New → Confirmed
NBrack (nbrack-soc) wrote :

Hey, I had the crash with extension->negate->color. With inkscape 0.48 on linux, it tells me "Inkscape encountered an internal error and will close now.", then, well, closes.

I tried to use a recent git version of inkscape (3-4 days ago or so), and though it still do no work, only the python engine crashes.

It pops up a dialog with the following text :

__________________________________

Inkscape has received additional data from the script executed. The script did not return an error, but this may indicate the results will not be as expected.

Traceback (most recent call last):
  File "color_negative.py", line 2, in <module>
    import coloreffect
  File "/home/nbrack-soc/Projects/shared_app/inkscape/build/share/inkscape/extensions/coloreffect.py", line 21, in <module>
    import sys, copy, simplestyle, inkex
  File "/home/nbrack-soc/Projects/shared_app/inkscape/build/share/inkscape/extensions/inkex.py", line 40
    u'sodipodi' :'http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd',
              ^
SyntaxError: invalid syntax
__________________________________

I know naught of python, but 'http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd' definitely do not exists anymore.
Since the script file seems a little outdated, I tried to fix the shebang to #!/usr/bin/env python2 instead of #!/usr/bin/env python, but it did not worked.

Alvin Penner (apenner) wrote :

not sure if this is the source of the problem, but the correct line, taken from bzr repository should read

u'sodipodi' :u'http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd',

source = http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/view/head:/share/extensions/inkex.py

jazzynico (jazzynico) wrote :

@NBrack - Your issue is not the same as the original reporter's. In your case, only the Python engine crashes, not the whole application.
Are you using Python 3 on your system? Inkscape's extensions are designed for Python 2.5+ only, and there are things (such as unicode strings with 'u') that don't work with Python 3. Could you please confirm?

jazzynico (jazzynico) wrote :

@Dana - Could you please update your Inkscape version (from http://sourceforge.net/projects/inkscape/files/inkscape/)? Some Windows specific libraries have been updated in 0.48.3.1, maybe it would fix your bug.

Kris (kris-degussem) on 2012-08-04
Changed in inkscape:
status: Confirmed → Incomplete
Kris (kris-degussem) wrote :

Closing report by lack of feedback.
If the problem reappears, feel free to revert the bug status.

Changed in inkscape:
status: Incomplete → Invalid
Windell Oskay (windell) wrote :

I have received a new report of the same issue, on a Win XP computer with 0.48.2. Extensions crash the system, even after a fresh re-install of Inkscape. For the moment, I'm advising an installation of 0.48.3.1 to see if that helps, and I'll report back here with the results.

Assuming that the situation remains unchanged, what kinds of debugging data could we try to collect to help resolve the issue?

Windell Oskay (windell) wrote :

Apparently 0.48.3.1 did not make any difference.

Also, this is apparently reproducible on two different computers running Win XP.

Changed in inkscape:
status: Invalid → Confirmed
su_v (suv-lp) wrote :

> I'm advising an installation of 0.48.3.1 to see if that helps

With Inkscape 0.48.3.1, please be aware of this (unfortunate) regression:
Bug #944077 “inkscape crashed with SIGSEGV in Inkscape::Extension::Implementation::Script::effect()”
<https://bugs.launchpad.net/inkscape/+bug/944077>

Workaround for affected files:
<https://bugs.launchpad.net/inkscape/+bug/944077/comments/11>

jazzynico (jazzynico) wrote :

@Windell Oskay - We have updated the Windows specific libraries again in Inkscape 0.48.4 (http://inkscape.org/download/). Would you please test it and confirm you're still affected?

Windell Oskay (windell) wrote :

Unfortunately, I no longer have access to those computers. I was unable to help the person that had those two computers, and ultimately had to just give up on using Inkscape for them. :(

@JazzyNico
I am still affected by this bug in Inkscape 0.48.4 r9939, on windows XP.
I get the same error messages trying to use extensions and also help-menu entries.
Please tell me how I can help with more information.

I can confirm this bug for 0.48.4 on Windows 7 x64. It is occuring randomly after a few minutes, Inkscape breaks with an error (0x40000015 in libglib-2.0-0.dll in the Windows log) and closes. The error in libglib-2.0.0 is very prominent in the net it also occurs for wireshark or gimp. I assume it is somehow connected with the Visual C++ Runtime - maybe a certain version is in conflict with libglib.

Anyone an idea how to solve this? Or a work around, or a bug fix?

Larry York (larry-york) wrote :

I also have this bug on Windows 7 x64, with Inskape 0.48.4. Inkscape closes after reporting an error. Windows log shows libglibmm-2.4-1.dll

I had this bug with random crashes for a long time but finally realized it correlated 100% with the 16-bit color depth I was forced to use. Changing the graphic configuration to 32-bit color depth resolved the problem.

Anyone who experiences this problem check your display settings. Inkscape has a memory leak at 16-bit color depth resulting in random crashes of memory violation but blaming the Visual C++ Runtime.

jazzynico (jazzynico) on 2016-09-15
summary: - 0.48 crashes (C++ Runtime Library) when using extensions
+ Inkscape crashes (C++ Runtime Library) when using extensions
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers