Node Tool grid snapping sometimes fails

Bug #630642 reported by zoqaeski on 2010-09-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Diederik van Lierop

Bug Description

Upon updating to Inkscape 0.48 I've noticed that the node tool sometimes fails to snap to a grid unless both the Snap to Grid and Snap to Guide option is selected. However, after toggling both these options and unsetting the Snap to Guide option, the snapping works as expected (i.e. the nodes snap to the grid or guide or both depending on the state of these options.)

This only seems to occur with existing drawings (created in earlier versions of Inkscape) with multiple grids enabled (but not necessarily visible, although always snap-enabled regardless of visibility).

Operating system is Arch Linux, fully up-to-date. (I guess version of OS is irrelevant for a rolling-release distro, isn't it?)

su_v (suv-lp) wrote :

> This only seems to occur with existing drawings (…)

Can you please attach a sample drawing?

tags: added: grids node-editing snapping
removed: 0.48 grid linux node snap
zoqaeski (zoqaeski) wrote :

It seems I'm unable to reproduce it myself let alone provide an example drawing that triggers it. It must have been some combination of the settings that did the trick but it's refusing to appear now. Earlier this afternoon nodes weren't snapping at all until I toggled the snap options on and off again, as though to reset their states I suppose. I may have had some residual configuration options (if that is possible) from an older version (I was using 0.47) which weren't detected initially with the new version until their state was reset.

I've attached the drawing which *had* the problem, although I'm not sure if that will help. Given that I can't reproduce the "bug" I'm not sure if it really was one now.

Thanks for taking the time to report this. If you do find a way to reproduce this then please let us know, and we'll gladly fix this!

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48 and 0.48+devel r9737 on OS X 10.5.8

If the node tool is used before any node snapping has occurred after opening/reverting the document (snap settings: snap nodes and handles to grid), cusp nodes do not snap to grid in the node tool context (unless snap target 'snap to cusp nodes' is activated).

Workarounds:
a) before using the node tool, perform a 'snap node to grid' action with the selection tool (drag a shape snapping one of the nodes to the grid)
b) in the node tool, drag and snap a smooth node to the grid.
After both actions cusp nodes will snap to the grid when editing a path with the node tool.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

correction: workaround b) doesn't work ;-) -- use this instead:
1) select a path and switch to node tool
2) activate snap target 'to cusp nodes', drag & snap one node to grid
3) deactivate snap target 'to cusp nodes' again
 -> now all dragged nodes snap to grid as expected.

It seems as if parts of the snapping context (snap targets) are not "initialized" in the node tool context when the document is loaded.

su_v (suv-lp) wrote :

"Workaround" works in 0.48 but not in 0.48+devel r9737 (using the same drawing and snap settings): in Inkscape trunk, when editing paths with the node tool, nodes snap to grid only if one of the node snap targets is activated, additionally to 'Snap to grid'.

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

This has been fixed, both in v0.48.x and in our development trunk.

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2010-10-02
Changed in inkscape:
milestone: none → 0.48.1
su_v (suv-lp) wrote :

inkscape trunk: r9783, r9784
inkscape 0.48.x: r9673

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments