V 0.48 inkscape.exe lists version as 0.47.0.9

Bug #628846 reported by Lawrence on 2010-09-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

I use Secunia Personal Software Inspector to check for software updates (http://secunia.com/). On my Windows Vista it reports Inkscape 0.48 as version 0.47.0.9 because that is what is listed in the properties of the inkscape.exe file. The exe is clearly the 0.48 and the last updated date is August of this year when the Windows installer was downloaded and run. The previous version 0.47 was removed by the installed and 0.48 was installed. Also the file properties list the copyright as "2009 Inkscape" so that should be changed to 2010.

To get the properties of the exe right click on it, select properties, click on tab for details.

Related branches

su_v (suv-lp) on 2010-09-02
tags: added: packaging win32
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape 0.48 and trunk version.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → JazzyNico (jazzynico)
jazzynico (jazzynico) wrote :

Chris, any idea? Since it also affects compressed nightly versions and home compiled versions, I guess it's not an installer issue (even if the date in the Version Information section is still 2009). But I'm a bit lost.

Chris Morgan (chris.morgan) wrote :

It seems the VersionInfo tables in src/inkscape.rc and src/inkview.rc weren't updated. I mentioned that it needed doing once shortly after 0.48 was branched, but then forgot to follow it up. (The .0.9 was for the benefit of +devel.)

I suppose we could add the contents of ink(scape|view).rc to build.xml and use ${version} and ${bzr.revision}, just like with inkscape-version.cpp. But then there's the problem that "bzr" may not be in the path. Also it'd need some extra code in buildtool, I think, to join 0.48+devel and 9740 to produce 0.48.0.9740 (or 0.48.0.9 if the revno can't be found) or so it could cope with three-part numbers like 0.48.1; I wrote such code for the installer in NSIS, but that's not much use for buildtool.cpp. What's more I read it from .bzr/branch/last-revision directly (it's the first word in the file) rather than using bzr revno because I found it often wasn't in the path.

For starters, I've updated trunk in r4741 to have 0.48+devel instead of 0.47+devel, 0.48.0.9 instead of 0.47.0.9 and 2010 instead of 2009 in the copyright. The 0.48 branch should also be updated similarly. (0.48 and 0.48.0.0, 0.48.1 and 0.48.1.0, or 0.48+devel and 0.48.0.9?)

jazzynico (jazzynico) wrote :

Thanks for the tips.

> What's more I read it from .bzr/branch/last-revision directly (it's the first word in the file) rather than using bzr revno because I found it often wasn't in the path.

That's something that can be improved. I used revno in order to be sure it also works with checkouts (in which there's no last-revision file), but buildtool.cpp should handle both cases. I'll try to work on it before the next revision.

> The 0.48 branch should also be updated similarly. (0.48 and 0.48.0.0, 0.48.1 and 0.48.1.0, or 0.48+devel and 0.48.0.9?)

0.48.0.revno would be perfect. But it would need the rc files to be updated automatically.

Lawrence (annon0m0s) wrote :

I know nothing about software builds so these comments may be completely useless. http://StackOverflow.com has interesting questions and often interesting answers. Problems related to propagating version numbers seems to be common so there seems to be more than a few answers with coded scripts but the specific one you would need would be dependent on what software is used for the build. I did a search on StackOverflow for +update +version +number +build. The plus sign is needed because the default search puts an OR between each term.
http://stackoverflow.com/search?q=%2Bupdate+%2Bversion+%2Bnumber+%2Bbuild

If four field version numbers were not a problem in 0.47.x.x then they won't be a problem in 0.48 but some Windows installers seem to ignore the fourth field so 0.48.0.1 would be the same as 0.48.0.2. But this likely does not matter to end users because by the time something is released to the public the version will be at least 0.48.1.
http://msdn.microsoft.com/en-us/library/aa370859%28v=VS.85%29.aspx

jazzynico (jazzynico) on 2010-09-16
Changed in inkscape:
milestone: none → 0.48.1
jazzynico (jazzynico) wrote :

rc files updated to 0.48.1.0 in revision 9669 (0.48.x branch).

Changed in inkscape:
status: Confirmed → Fix Committed
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Triaged
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers