OS X System Font No Longer Smoothed In 0.48

Bug #625668 reported by ArrowJ on 2010-08-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

After updating to 0.48 from 0.47 the UI fonts are no longer smoothed (anti-aliased) on my laptop LCD. I have attached a screenshot of the menu. You can see that the titlebar which is part of the Mac OS is anti-aliased while the Inkscape menu is not.

Mac OS X 10.6.4
Inkscape 0.48

su_v (suv-lp) wrote :

reproduced with Inkscape 0.48.0-1 on OS X 10.5.8, XQuartz 2.4.0

Possibly due to changes in latest release of freetype?

tags: added: packaging
removed: fonts mac
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

Note: does not affect font rendering on canvas or export.

su_v (suv-lp) wrote :

Workaround:
1) quit Inkscape
2) Inside the application bundle:
copy
 Contents/Resources/etc/fonts/conf.avail/10-autohint.conf
to
 Contents/Resources/etc/fonts/conf.d
3) restart Inkscape

Optionally re-enable the system fonts directory in
 Contents/Resources/etc/fonts/fonts.conf
to have 'Lucida Grande' available as GUI font.

I'll attach a patch for the packaging routines later (for auto-hinting).

su_v (suv-lp) wrote :

r13620

Changed in inkscape:
milestone: none → 0.91
status: Confirmed → Fix Committed
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers