segfault in sp_event_context_virtual_item_handler

Bug #622350 reported by sam tygier on 2010-08-22
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski

Bug Description

reproducable crash with Inkscape 0.48.0 r9654 built from tarball.

1 open inkscape
2 create a rectangle, and convert it to a path (i think it needs to be filled)
3 use the 'edit path by node' tool
4 drag the top edge of the rectangle into a curve that passes below the bottom edge of the rectangle
5 press control+x (i found this by miss hitting undo).

if it does not crash undo the cut, and the edit of the top edge, and repeat from 4. sometimes it takes several repetitions.

backtrace attached

sam tygier (samtygier) wrote :
su_v (suv-lp) on 2010-08-22
tags: added: crash node-editing
Changed in inkscape:
importance: Undecided → High
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.

Easier steps:
1. Draw a line with the pen or pencil tool.
2. Select it with the node tool.
3. Press Ctrl+X.
4. Undo and try Ctrl+X again.

Not reproduced with 0.47.

Changed in inkscape:
milestone: none → 0.48.1
status: New → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

reproduced with Inkscape 0.48.0 and 0.48+devel r9720 on OS X 10.5.8

Inkscape doesn't fully crash here but hangs after writing the emergency save file (see attached sample of the inkscape-bin process after the crash)

jazzynico (jazzynico) wrote :

@Diederik: I'm not sure it's the cause of the crash, but Inkscape crashes when reaching a code you've modified recently. Would you be willing to take a look and confirm its related? Thanks!

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

Inkscape shouldn't crash any longer in this case (as of rev. #9728).

What happened was that while changing or resetting the node tool (or any other tool too), the desktop->event_context was NULL for a short period of time. This makes it impossible to process any events during that short period, but there has never been a check implemented to prevent this from happening. I've merely added a safety check which discards those inconvenient events.

The new node tool however did happen to generate a such inconvenient events, because when setting up the node tool it is assumed that the selection has changed, which again invokes a screen update, leading to GDK_LEAVE_NOTIFY events. I'll ask Krzysztof if he can look into this. Maybe it can be avoided to update the screen when setting up the node tool.

Changed in inkscape:
status: Confirmed → Fix Committed

I tried assigning this bug to Krzysztof, but apparently I can no longer assign it to a person but only to a team?

jazzynico (jazzynico) on 2010-08-28
Changed in inkscape:
assignee: Diederik van Lierop (mail-diedenrezi) → Krzysztof Kosinski (tweenk)

Thanks JazzyNico!

su_v (suv-lp) wrote :

Diederik van Lierop wrote:
> apparently I can no longer assign it to a person but only to a team?

Most likely due to recent changes in launchpad:
<http://blog.launchpad.net/general/assigning-bugs-to-someone-else-or-not>

Bug #603281 in Launchpad Bugs: “bug assignment permissions too restrictive”:
<https://bugs.edge.launchpad.net/malone/+bug/603281>

jazzynico (jazzynico) wrote :

Thanks for your patch.
Could you please apply it to the 0.48.x branch? Since this is a regression, it would be nice to have it fixed in 0.48.1.

Apparently bug management can only be done by the Inkscape bug team.
I've added your name in the member list.

Yes of course, thanks for the reminder. This fix has now also been backported

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers