Gimp XCF export warning when exporting an empty grid

Bug #616330 reported by jazzynico on 2010-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

Reproduced on Ubuntu 10.04, Inkscape 0.47.

Steps:
1. Create a document with no grid.
2. Export it to Gimp XCF (export grid checked).
3. The document is correctly exported, but the script returns the following unnecessary (from a user's point of view) message:

No matching node for expression: sodipodi:namedview/inkscape:grid[@type='xygrid' and (not(@units) or @units='px')]

jazzynico (jazzynico) on 2010-08-11
tags: added: exporting xcf
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
jazzynico (jazzynico) on 2010-08-11
Changed in inkscape:
status: New → In Progress
jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 9699.

The script now tests if a grid exists before exporting it.

The file is available on launchpad (http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/annotate/head%3A/share/extensions/gimp_xcf.py). To test the fix with 0.47 or 0.48, copy the downloaded file to the Inkscape share/extensions folder.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Fix backported to 0.48.x branch (revision 9660).

Changed in inkscape:
milestone: 0.49 → 0.48.1
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers