Gimp XCF export doesn't work on Windows

Bug #616193 reported by jazzynico on 2010-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

I've tweaked my system and Gimp installation so that XCF export shows in the menu (Gimp path added to the PATH env, and gimp-2.6.exe duplicated and renamed gimp.exe) but using it returns a script error message:

---
Traceback (most recent call last):
  File "gimp_xcf.py", line 189, in <module>
    e.affect()
  File "C:\Devel\Inkscape\bzr\inkscape\share\extensions\inkex.py", line 215, in affect
    self.effect()
  File "gimp_xcf.py", line 183, in effect
    x = open(xcf, 'r')
IOError: [Errno 2] No such file or directory: 'c:\\docume~1\\nico\\locals~1\\temp\\tmp8s3dqw\\test.xcf'
---

The temp folder contains the extracted layers (png files) and a junk file created by Gimp (attached).
According to the junk file messages, the extension fails because Gimp (or the scheme interpreter) can't find the layer files, and thus can't create the XCF file.

jazzynico (jazzynico) wrote :
tags: added: exporting xcf
description: updated
jazzynico (jazzynico) wrote :

Issue already mentioned (but not detailed) in Bug #171687 "GIMP XCF extension, PSD and other layered formats" (https://bugs.launchpad.net/inkscape/+bug/171687).

jazzynico (jazzynico) on 2010-08-11
Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
importance: Undecided → Medium
milestone: none → 0.49
status: New → In Progress
jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 9699.

The file is available on launchpad (http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/annotate/head%3A/share/extensions/gimp_xcf.py). To test the fix with 0.47 or 0.48, copy the downloaded file to the Inkscape share/extensions folder (on Windows, it's in C:\Program Files\Inkscape\share\extensions).

Don't forget to add the Gimp path in the Path environment var, and to rename gimp-2.6.exe to gimp.exe...

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

Fix backported to 0.48.x branch (revision 9660).

Changed in inkscape:
milestone: 0.49 → 0.48.1
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers