Crash when editing SVGs produced by FontForge

Bug #614751 reported by Alexandre Prokoudine on 2010-08-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

Inkscape crashes whenever I try to do anything with SVG files produced by FontForge. When crashing, it saves a temporary file, but as soon as I open it and select any object, Inkscape crashes again.

GDB is completely useless, because Inkscape doesn't work with it cleanly. That is, when I run Inkscape from gdb, and crash occurs, the desktop becomes completely locked, the only thing I can do is Ctrl+Alt+F1 to switch to console and bloody kill gdb. The only thing I see after that is:

[Thread debugging using libthread_db enabled]
terminate called after throwing an instance of 'Geom::InfiniteSolutions'
  what(): lib2geom exception: There are infinite solutions (./2geom/hvlinesegment.h:164)

Program received signal SIGABRT, Aborted.
0x0012d422 in __kernel_vsyscall ()
(gdb)

I've been experiencing incorrect gdb related behavior by Inkscape for years. Apparently I'm the only person to see it, because after all these years it hasn't been fixed yet. Perhaps it has something to do with the ugly way Inkscape reports the error and tells where the file is saved. E.g. on Linux (Ubuntu 10.04 as of now) the focus is automatically on the "Close" button in the report dialog and mouse pointer is the one from Selector tool wherever you move it too, including areas of desktop that have nothing to do with Inkscape's windows.

Until this stupid misbehavior is fixed, I cannot provide a real backtrace, sorry. A sample file will be attached though.

Steps to reproduce a crash with this sample file:

1. Open
2. Select any of the objects
3. See Inkscape misbehaving

100% reproducible on 0.48+devel r9665, but I've seen this on clean 0.48pre and before too.

su_v (suv-lp) wrote :

In parts reproduced with Inkscape 0.48+devel r9692 on OS X 10.5.8:

The crash is not triggered by just selecting one of the paths, but when dragging nodes in the node tool.

tags: added: crash node-editing
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
su_v (suv-lp) wrote :

reproduced with Inkscape 0.47 r22583 on OS X 10.5.8:

The crash happens when dragging nodes of the 'L' shaped path in the node tool.

su_v (suv-lp) wrote :

Same console message with both Inkscape versions:

terminate called after throwing an instance of 'Geom::InfiniteSolutions'
  what(): lib2geom exception: There are infinite solutions (./2geom/hvlinesegment.h:164)

tags: added: 2geom
su_v (suv-lp) wrote :

> GDB is completely useless, because Inkscape doesn't work with it
> cleanly. That is, when I run Inkscape from gdb, and crash occurs, the
> desktop becomes completely locked, the only thing I can do is
> Ctrl+Alt+F1 to switch to console and bloody kill gdb.

Does <http://wiki.inkscape.org/wiki/index.php/Debugging_Inkscape#Debugging_Tips_for_Linux> help? (start gdb from the console, then switch back to X)

su_v (suv-lp) wrote :

Crash not reproduced if both letters are ungrouped first before node-editing the 'L' (-> converting preserved into optimized transforms, rewriting the path data).

The groups originally have these transforms:
 matrix(1 0 0 -1 0 800)
 matrix(1,0,0,-1,88.40873,524.97143)

Jon A. Cruz (jon-joncruz) wrote :

Note that running valgrind can often spot an initial cause of corruption, as opposed to the sometimes much later cascading result of crashes.

I've just tried that horrible trick with console and I cannot make Inkscape crash so far.

Johan Engelen (johanengelen) wrote :

Does not crash when snapping is disabled...

Johan Engelen (johanengelen) wrote :

Fixed in r9845

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Johan Engelen (johanengelen)
su_v (suv-lp) wrote :

inkscape trunk: r9845
inkscape 0.48.x: r9696

Changed in inkscape:
milestone: none → 0.48.1
su_v (suv-lp) wrote :

Crash as described in comment #2 and #3 no longer reproduced with Inkscape 0.48+devel r9845 on OS X 10.5.8.

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers