Add metadata default configuration in the preferences

Bug #612221 reported by jazzynico on 2010-08-01
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
John Smith

Bug Description

Report based on Question #119535 by Michel Cadiou.

With Inkscape it is already possible to set metadata
for each document. And that is a good thing to be able
to do so.

But if one has many documents, in the same context,
in a raw or all the time, it's tedious to fill the
metadata again and again and it's error prone.

A possible solution to that would be to add a software-wide
metadata configuration in the preferences. And when a new
document is created, it would be initialized with the software-wide
metadata if those are present. Then the metadata present on
the document could still be modified, just like they are today,
on a per-document basis.

Would you find it useful too? Would it be possible to implement?

jazzynico (jazzynico) wrote :

Yes, I think it would be useful, and probably not too difficult to implement.

tags: added: metadata preferences
Changed in inkscape:
importance: Undecided → Wishlist
status: New → Confirmed
Bernard Lang (bllaunchpad) wrote :

With current copyright laws, it is not possible to reuse a drawing, even freely accessible, unless the copyright information (CC for example) is specified somewhere. It is also not allowed not to put the author's name in some countries. Hence everyone can benefit, author and users, if these informations are included automatically, as many authors forget them.

John Smith (john-smithi) wrote :

Attached is a patch to implement some basic "default metadata" features, by adding 2 buttons on the Metadata dialog to load and/or save "default" metadata to user preferences.xml

Note: One issue with default metadata is that the multiline metadata is not correctly loaded (loaded without the newlines) from preferences , seems to be an issue with the preference loading function .. looking into this.

Could also perhaps add a checkbox to Inkscape Preferences to "Add default metadata to new documents".

Any other suggestions or comments ?

su_v (suv-lp) wrote :

> Could also perhaps add a checkbox to Inkscape Preferences
> to "Add default metadata to new documents".

What if I use custom templates which include some metadata (and/or license) information? Would this setting override templates, or only be in effect if the used template doesn't provide any defaults?

John Smith (john-smithi) wrote :

> What if I use custom templates which include some metadata (and/or license) information?
Good question, which is preferred ? I would think custom templates should override the default preferences , but either can be done of course ...

John Smith (john-smithi) wrote :

Instead of saving the "default metadata" to properties.xml, would it be preferred to save it in the default.svg template file ?

Bonjour,

Désolé de vous répondre en français.
Je suis Français et handicapé, ce qui fait 2 handicaps...
Ma demande initiale est une idée/demande personnelle mais rédigée par
d'autres en anglais.

Si l'un des 2 fichiers est réutilisée en cas de ré installation de
Inkscape, il serait bienvenu de l'utiliser ?

PS : comme je ne maitrise ni l'anglais, ni l'installation des paquets,
je n'arriverai pas à installer le patch. Dommage.

Mais notre fils ingénieur informatique nous rend visite en septembre...

Merci pour votre engagement libre.
--
Michel Cadiou

Le 21/05/12 04:21, John Smith a écrit :
> Instead of saving the "default metadata" to properties.xml, would it be
> preferred to save it in the default.svg template file ?
>

John Smith (john-smithi) wrote :

Attached patch adds these features
1) Optionally add default metadata to new documents (default is off)
2) User preference "Input/Output -> Add default metadata to new documents" for 1)
3) Default metadata (stored in users preference file) is not added to a new document created with a template that already includes metadata (ie does not override the template)

@Michel, if you have an existing proposal I would be happy to read it.

John Smith (john-smithi) wrote :

Committed to trunk as r11544. Features as per comment #8.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
status: Confirmed → Fix Committed
Kris (kris-degussem) on 2012-09-06
Changed in inkscape:
milestone: none → 0.49
Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions