On-screen rendering of background colour is off by 1

Bug #611345 reported by Teki on 2010-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Krzysztof Kosinski

Bug Description

As noted by ~suv:

"Reproduced with Inkscape 0.46, 0.47 and 0.48+devel r9669 on OS X 10.5.8 - but only for on-canvas rendering, bitmap export does not show this shift of 1:

bg values set to rgb(0, 0, 0) renders as rgb(0, 0, 0) (black)
bg values set to rgb(1, 1, 1 ) renders as rgb(0, 0, 0)
bg values set to rgb(128, 128, 128) renders as rgb(127, 127, 127) (OPs example)
bg values set to rgb(255, 255, 255) renders as rgb(254, 254, 254) (not quite white)"

su_v (suv-lp) wrote :
Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

@Teki - could you add information about your platform and Inkscape version, too?

su_v (suv-lp) on 2010-07-29
tags: added: color ui
Teki (teknocide) wrote :

Sure, I'm running Inkscape 0.48pre1 r9509 on Windows 7 x64

su_v (suv-lp) wrote :

No longer reproduced with Inkscape 0.48+devel r10892
tested on OS X 10.7.2 Lion and compared to Inkscape 0.48.2

su_v (suv-lp) wrote :

Please reopen if the difference can still be reproduced with current trunk.

Reproduced with 0.48+devel r10325 (old renderer),
not reproduced with latest revision from cairo-rendering branch,
not reproduced with r10330 and later revisions in current trunk.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.49
status: Confirmed → Fix Committed
su_v (suv-lp) on 2012-01-16
tags: added: renderer
Changed in inkscape:
importance: Undecided → Low
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers