Crash after deleting pattern source of 'Pattern Along Path' LPE

Bug #607557 reported by Steven Holte on 2010-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen

Bug Description

1) Create a path with a pattern along path effect applied to it.
2) From the pattern along path panel, choose to edit the pattern on canvas.
3) Delete the pattern.
4) Click somewhere else on the canvas

Inkscape crashes.

su_v (suv-lp) wrote :

Please add information about your os and Inkscape version.

tags: added: crash livepatheffects
Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

In parts reproduced with Inkscape 0.48pre1 and 0.48+devel r9630 on OS X 10.5.8

> 4) Click somewhere else on the canvas

The crash only happens (after deselecting by clicking somewhere else on canvas) at the moment of reselecting the path again:

4) switch to the select tool and deselect all
5a) select the path with the select tool -> crash
 or:
5b) select the path in the XML Editor -> crash

Not reproduced with Inkscape 0.47: when deleting all nodes of the pattern, the path itself is deleted as well.

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2010-07-20
summary: - Deleting pattern along path crashes inkscape
+ Crash after deleting pattern source of 'Pattern Along Path' LPE
Johan Engelen (johanengelen) wrote :

fixed in r9653

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
su_v (suv-lp) wrote :

Setting Status to 'Fix Released' in accordance to <http://wiki.inkscape.org/wiki/index.php/Bug_management#Bug_status> because the bug only appeared in the development version, and was not encountered in a stable release.

Changed in inkscape:
assignee: Johan Engelen (johanengelen) → nobody
milestone: none → 0.48
status: Confirmed → Fix Released
su_v (suv-lp) wrote :

reverting assignment change, sorry for that.

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers