Can't edit stroke pattern unless there is a fill pattern

Bug #604025 reported by Nikola Kovacs on 2010-07-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Liam P. White

Bug Description

Create a path. Set the stroke to a pattern. Set the fill to anything else. Select the node tool. The pattern editing handles are nowhere to be found.

You have to set the fill to pattern to get the handles, which means if your fill was a gradient, it will be reset. If you later decide to tweak the pattern after you've set the fill to something else again, you'll have to set the fill to pattern again, which will reset the pattern handles (but not the actual pattern on the stroke, though that doesn't matter because trying to use the pattern handles will reset the pattern).

su_v (suv-lp) wrote :

Linking as duplicate to bug #486192 “In the node editor, both stroke and fill use the same pattern handles”
<https://bugs.launchpad.net/inkscape/+bug/486192>

Please add a comment here and revert the duplicate status if you don't agree and think these are different issues.

tags: added: node-editing pattern
Nikola Kovacs (nx) wrote :

I disagree, that bug is about being able to edit the stroke and fill patterns separately, and is a wishlist. This is a bug, unless you figure out that you have to make the fill a pattern too, you'll be scratching your head looking at the top left of the canvas wondering where the pattern handles are.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9602 on OS X 10.5.8

Fixing this bug IMHO should also address bug #486192 (allow separate handles for fill pattern and stroke pattern).

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Liam P. White (liampwhite) wrote :

Fix committed in lp:inkscape, r13489.

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Liam P. White (inkscapebrony)
su_v (suv-lp) on 2014-08-04
Changed in inkscape:
milestone: none → 0.91
su_v (suv-lp) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers