Inkscape crashes when trying to move or rotate stroke pattern

Bug #601336 reported by Nikola Kovacs on 2010-07-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Liam P. White
Experimental
High
Liam P. White

Bug Description

Open the attached file. Click the object in the lower right. The pattern control points will appear to the left of the canvas.

If you try to move the pattern, Inkscape will crash.
If you try to rotate the pattern, Inkscape will crash.
If you try to scale the pattern, it will scale a little then stop. After this, the bug will disappear, i.e. you can scale, rotate and move without any problems.
Similarly, if you move the object first, the bug will also disappear.

Related branches

Nikola Kovacs (nx) wrote :
Nikola Kovacs (nx) wrote :

Never mind, I can't reproduce it in the devel version.

Changed in inkscape:
status: New → Invalid
Nikola Kovacs (nx) wrote :

Ok, this one is crashing on r9590. You first have to set the fill to pattern to make the handles appear, then try to move the pattern.

Changed in inkscape:
status: Invalid → New
~suv (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9602 on OS X 10.5.8

a) crash when moving the pattern

b) no crash when moving the pattern after scaling it, scaling produces this console message:
(inkscape-bin:90943): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `SPKnot'

tags: added: crash node-editing pattern
Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
~suv (suv-lp) on 2010-07-11
summary: - Inkscape crashes when trying to move or rotate pattern
+ Inkscape crashes when trying to move stroke pattern
summary: - Inkscape crashes when trying to move stroke pattern
+ Inkscape crashes when trying to move or rotate stroke pattern
~suv (suv-lp) wrote :

reproduced with Inkscape 0.47 r22583 on OS X 10.5.8

With Inkscape 0.47 I can only reproduce the crash the second time I open the document in the same session - the first time, the pattern handles can be moved without crash.

console message when crashing:

** (inkscape-bin:10914): CRITICAL **: void SPObject::requestDisplayUpdate(unsigned int): assertion `this->document != NULL' failed

Possibly related to bug #271723 “Segmentation Fault (crashes) when I try to move a large pattern” (see comment #12)?
<https://bugs.launchpad.net/inkscape/+bug/271723>.

~suv (suv-lp) wrote :

crash still reproduced with Inkscape 0.48+devel r9867 on OS X 10.5.8 (same backtrace as in comment #4)

jazzynico (jazzynico) wrote :

Updated GDB backtrace (Crunchbang Waldorf, Inkscape trunk revision 13446).

Changed in inkscape:
status: Confirmed → Triaged
ScislaC (scislac) wrote :

I ran into this in both trunk and experimental without the example file.

Steps to reproduce:

1) Create object (I did a rectangle)
2) Open F&S Dialog
3) Switch Fill to Pattern
4) Switch Stroke to Pattern
5) Attempt to rotate or resize pattern with on-canvas controls.

ScislaC (scislac) on 2014-07-16
tags: added: blocker
Johan Engelen (johanengelen) wrote :

Can't reproduce (win32, trunk rev13434)
One thing to note: I don't see the handles for the stroke pattern, and so I can't change it. (another bug?)

Changed in inkscape:
status: Triaged → Fix Committed
assignee: nobody → Liam P. White (inkscapebrony)
Changed in inkscape:
status: Fix Committed → In Progress
Liam P. White (inkscapebrony) wrote :

@Johan

see bug #604025

Liam P. White (inkscapebrony) wrote :

Fix proposed for trunk

- Adds support for the ability to modify both stroke and fill patterns independently, fixing bug bug #604025 (and earlier duplicate bug #486192)
- Needs testing

Liam P. White (inkscapebrony) wrote :

Fix committed in lp:inkscape, r13489.

Changed in inkscape:
status: In Progress → Fix Committed
~suv (suv-lp) on 2014-08-04
Changed in inkscape:
milestone: none → 0.91
tags: removed: blocker
Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers