"Previous Extension" and "Previous Extension settings" menu items point to the last opened help document, e.g. to FAQ

Bug #600671 reported by Nizamov Shawkat on 2010-07-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

I am trying inkskape 0,48 - pre on Windows XP. If user selects "Previous Extension" and "Previous Extension settings" menu items, he will be redirected to the last opened document in browser, e.g. to FAQ.

how to reproduce

1) start inkskape
2) click on "FAQ" in menu
3) see the browser with corresponding page
4) click on "Previous Extension" or "Previous Extension settings"
5) observe the FAQ again (no, there is nothing related to previous extension settings :))
5) click on "Keys and mouse reference" in menu
6) see the corresponding page
7) click on "Previous Extension" or "Previous Extension settings"
8) observe the browser with keys and mouse reference

A small addition:
When inkscape is just started, "Previous Extension" and "Previous Extension settings" menu items are disabled. But after clicking "FAQ" menu item, they will be enabled. Probably, actually this is a problem.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47 and 0.47+devel r9542 on OS X 10.5.8

All menu entries in the help menu that open a web page are using a python script extension - technically that's why they are repeated when using 'Previous Extension'. I don't know if extensions can be selectively excluded from the 'Previous Extension' related commands.

tags: added: extensions-plugins
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed

I have just written a small patch to solve this bug. Please test.

Changed in inkscape:
status: Confirmed → In Progress
assignee: nobody → Craig Marshall (craig9)
su_v (suv-lp) wrote :

Hard-coding script extensions names (used as verbs?) to be excluded hides the issue IMHO and is error-prone because the names in the script extension definition files (*.inx) can be changed at any time without requiring updating the sources and recompiling.

Maybe extensions need a hidden parameter that indicates their scope and whether they register as 'repeatable' extension? Or maybe extensions could be excluded from registering as 'last effect used' based on the menu they list themselves in instead of depending on arbitrary names?

~suv, I agree completely. I have looked closer at the relevant parts and have found an alternative solution. Before I code it up, I wonder if you'd give it some thought and see whether this would be suitable. It seems to me that it would be much nicer than my current solution, and almost as nice as adding a custom "no-repeat" attribute and supporting code.

In the inx files, the id of each help effect starts with "org.inkscape.help.". If I were to check for this id prefix instead of the actual names, then any future name changes or additions to the menu could be done freely without adjusting this code. (So long as they adhere to the unenforced standard of being named org.inkscape.help.foo, or similar.

Would this be a good solution?

jazzynico (jazzynico) wrote :

Parsing the INX id is indeed a good idea. Its structure shouldn't move in the near future.

I've redone the fix now, here is a new patch which is a lot better than the old. Thanks both for the testing/comments.

jazzynico (jazzynico) wrote :

Tested successfully on Ubuntu 10.04, Inkscape 0.48. Please commit (trunk and branch)!

Changed in inkscape:
milestone: none → 0.48.1

This patch is committed now in both the trunk (revision 9799) and the 0.48.x branch (revision 9676).

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers