Convert old dialogs to dockable dialogs

Bug #592323 reported by Shawn B on 2010-06-10
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Unassigned

Bug Description

This dialog tracks the transformation of old style dialogs to dockable dialogs.

Tags: ui Edit Tag help
su_v (suv-lp) on 2010-06-10
tags: added: fonts ui
removed: dock font
Changed in inkscape:
importance: Undecided → Wishlist
su_v (suv-lp) wrote :

Other dialogs that can't be docked:

- Gradient Editor (bug #390458)
- Export Bitmap (bug #390458)
- Tiled Clones (bug #251674)
- XML Editor
- Object Properties

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

… continued:

- Image Properties
- Find dialog
- Check spelling

Kris (kris-degussem) wrote :

Object properties dialog now dockable

su_v (suv-lp) wrote :

> Object properties dialog now dockable

Changed in revision 10862:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/10862>

Kris (kris-degussem) on 2012-01-14
Changed in inkscape:
assignee: nobody → Kris (kris-degussem)
Kris (kris-degussem) wrote :

Image attributes and Link attributes are now diable (trunk revision 10910)

Changed in inkscape:
status: Confirmed → In Progress
Kris (kris-degussem) wrote :

Current to do list:
- Text and font settings
- Check spelling
- XML Editor
- Find dialog
- Gradient Editor (bug #390458)
- Export Bitmap (bug #390458)
- Tiled Clones (bug #251674)

su_v (suv-lp) wrote :

with regard to
- Find dialog
please coordinate with
Bug #909328 “Find / Replace dialog” (WIP)
<https://bugs.launchpad.net/inkscape/+bug/909328>

su_v (suv-lp) wrote :

Current to do list (cont.):
- Extensions dialog with options from the INX file (bug #929361)

su_v (suv-lp) wrote :

Update:
- Text and font settings (bug #930535)

summary: - dockable text and font settings
+ Convert old dialogs to dockable dialogs
John Smith (john-smithi) wrote :

Patch for Text and font added to bug #930535.

Kris (kris-degussem) wrote :

Current to do list:
- Check spelling
- XML Editor
- Find dialog (to coordinate with Bug #909328 “Find / Replace dialog” (WIP))
- Gradient Editor (bug #390458)
- Export Bitmap (bug #390458)
- Tiled Clones (bug #251674)
- Extensions dialog with options from the INX file (bug #929361)

ScislaC (scislac) wrote :

A rewrite of the Gradient Editor dialog needs to be done before anyone worries about docking. As I've mentioned previously on the mailing list, if the dialog doesn't get a rewrite during the 0.49 dev cycle, it will be disabled prior to release (it's pretty broken right now and hasn't been maintained over the years).

ScislaC (scislac) wrote :

While the gradient editor does need a rewrite, it appears that the broken behavior issues are due to a disconnect between the canvas and the editor. Making it dock prior to a rewrite would be acceptable in this case.

John Smith (john-smithi) wrote :

SpellCheck (bug #934721) in progress.

Kris (kris-degussem) wrote :

In progress:
- Check spelling
- Find dialog (to coordinate with Bug #909328 “Find / Replace dialog” (WIP))
- Gradient Editor (bug #390458)
- Export Bitmap (bug #390458)

Current to do list:
- XML Editor
- Tiled Clones (bug #251674)
- Extensions dialog with options from the INX file (bug #929361)

John Smith (john-smithi) wrote :

SpellCheck (bug #934721) commited
Export Bitmap (bug #390458) needs testing
XML Editor (bug #940715) in progress

John Smith (john-smithi) wrote :

Export Bitmap (bug #390458) committed.
XML Editor (bug #940715) committed.

Gradient Editor (bug #950677) - may be disabled

Kris (kris-degussem) wrote :

In progress:
- Find dialog (Bug #909328) - in test, about to commit
- Gradient Editor (bug #390458) - may be disabled

Current to do list:
- Tiled Clones (bug #251674)
- Extensions dialog with options from the INX file (bug #929361)

John Smith (john-smithi) wrote :

Find dialog (Bug #909328) committed.
Tiled Clones (bug #251674) committed.

Kris (kris-degussem) wrote :

Update: "Extensions dialog with options from the INX file (bug #929361)" is the last remaining item thanks to all fixes ofJohn.

Kris (kris-degussem) on 2012-05-08
Changed in inkscape:
milestone: none → 0.49
Kris (kris-degussem) on 2012-07-09
tags: removed: fonts text
description: updated
Kris (kris-degussem) wrote :

1 added to the list, 2 remaining:
- bug #1035013: make guides dialog dockable
- bug #929361: extensions dialog with options from the INX file

Kris (kris-degussem) on 2012-09-09
Changed in inkscape:
assignee: Kris (kris-degussem) → nobody
Kris (kris-degussem) on 2012-11-25
Changed in inkscape:
milestone: 0.49 → none

The font dialog really needs to be dockable. Perhaps at the bottom of the window. So long as it doesn't auto resize like it does now :)

jazzynico (jazzynico) wrote :

@Roland - Most dialogs (including the Text and fonts dialog) are dockable in Inkscape 0.91.
The only remaining non-dockable dialog types are listed in comment #21 (see follow-up reports).

Changed in inkscape:
milestone: none → 0.91
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints