[connectors] 'z' segments closing a path are ignored

Bug #591586 reported by su_v on 2010-06-09
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Johan Engelen

Bug Description

Due to changes in revision 9076 and 9079 'Prevent a redundant closing line segment being added when converting a rectangle, star or polygon to a path.' connector lines between closed paths/shapes do not start at the object boundary if crossing a 'z' segment (even for shapes).

Steps to reproduce:
1) draw a rectangle 'A'
2) draw a rectangle 'B' to the left of it
3) connect both with the connector tool

Expected result:
Connector line between the object borders

Actual result:
The left border of the right rectangle 'A' is ignored and the connector line connects to the midpoint of the rectangle

4) move rectangle 'A' below 'B'

Expected and Actual Result:
Connector line between the object borders

Workaround:
None. Affects all closed shapes and objects created with Inkscape after r9076/9079.

same underlying issue as reported in
Bug #590486 “[snapping] snap node to midpoint of 'z' segment closing a path fails”
Bug #586597 in Inkscape: “Fractalize extension removes segment”
Bug #542260 “Motion extension ignores 'z' segments”

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape r9451.

The shapes are not affected if you add a small amount of rx or ry (rectangles) or rounded (stars).

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

> The shapes are not affected if you add a small amount
> of rx or ry (rectangles) or rounded (stars).

… because the closing segment is a curve now, it is not redundant and cannot be replaced with 'z'.

Johan Engelen (johanengelen) wrote :

I fixed it in r9859
(also committed upstream)

Changed in inkscape:
status: Confirmed → Fix Committed
assignee: nobody → Johan Engelen (johanengelen)
Changed in inkscape:
milestone: none → 0.48.1
su_v (suv-lp) wrote :

inkscape trunk: r9859
inkscape 0.48.x: r9704

Fix confirmed with Inkscape 0.48+devel r9859 on OS X 10.5.8 (thx @Michael and @Johan for investigating and fixing!)

@Johan - could you possibly also take a look at bug #606859 “Knot LPE ignores not-redundant 'z' segments” (similar regression, still reproducible with r9859)?
<https://bugs.launchpad.net/inkscape/+bug/606859>

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers