"Affect:" toolbar label should be renamed/removed

Bug #590686 reported by Michael Doube on 2010-06-07
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: inkscape

The tool controls bar for the Select tool contains a button group with the label "Affect:". This label is inappropriate for a couple of reasons:

1. False implication that the buttons apply some sort of visual effect (blur, noise etc). The buttons actually control the effects of scale/move operations on borders, gradients and patterns.

2. Grammatical inconsistency. Most (perhaps all?) other toolbar labels are nouns for the related property ("Width:", "Force:", "Angle X" etc). "Affect:" is a verb.

It would make sense to either remove the label or replace it with a suitable noun for the property being adjusted (maybe something like "Scale/move properties:" but less verbose!)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: inkscape 0.47.0-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
Date: Mon Jun 7 09:45:55 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100412)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: inkscape

Michael Doube (michael-doube) wrote :
Michael Doube (michael-doube) wrote :
Changed in inkscape:
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: New → Confirmed
Changed in inkscape:
importance: Undecided → Low
Maximilian Albert (cilix) wrote :

I'm not a native speaker so take this with a grain of salt. However, I think that the use of the verb form is intentional, and it actually makes more sense to me. For it's not the case that pressing any of those toolbar buttons applies any kind of 'effect' (noun) on the selected objects. Rather, the buttons specify those properties of the selection which scaling or moving should 'affect' (verb). I'm setting the bug status to 'incomplete' to wait for more opinions from other developers or users.

Changed in inkscape:
status: Confirmed → Incomplete
Changed in inkscape (Ubuntu):
status: Confirmed → Incomplete
Michael Doube (michael-doube) wrote :

I see what you mean, and I will have a think about another word that might better indicate what is affected by a transformation.

Michael Doube (michael-doube) wrote :

On second thought, why is that toolbar label (Affect:) needed at all? It just takes up space, you have to read a tooltip to know what it means, and the tooltip is redundant anyway because each button has its own tooltip.

Alex Valavanis (valavanisalex) wrote :

Status set to "Opinion" so the discussion can progress prior to passing this on to the developers.

Changed in inkscape (Ubuntu):
status: Incomplete → Opinion
Changed in inkscape:
status: Incomplete → Opinion
tags: added: ui
Tom Nickell (wnickell) wrote :

I have been directed here after posting this bug independently: My post was a duplicate.

Regarding Alex's comment: This is not ambiguous at all. The correct (and common in this context) usage is "Effect". "Effect" is a noun. You are applying an "Effect". The action applied "Affects" the object to produce the desired "Effect".

As to priority, this obviously does not "Affect" function; however, it will have the "Effect" of annoying anyone competent in English usage.

Just change it.

Alex Valavanis (valavanisalex) wrote :

@Tom - I wasn't suggesting ambiguity... As Maximillian stated in comment #3, the trouble is that the buttons do not actually apply any sort of "effect" as the word is most commonly understood in graphics software (e.g. blur, noise etc...), so "Effect:" would also be an incorrect label for the group.

The buttons actually toggle common behaviour options for the "select and transform objects" tool. I think the best thing would be to remove the label entirely.

Tom Nickell (wnickell) wrote :

Alex, Maximillian,

Sorry if I jumped in too hard.

The problem is that the "Affect"/"Effect" confusion is very common and a continual frustration to educators. Anybody accustomed to grading papers will feel an irresistible urge to go after the text with a blunt red inkpen.

(I suspect that inability to distinguish the two is responsible for the lamentable substitution of the corporatism "impact" for "affect". )

I agree that if the buttons to not produce "Effects" as commonly understood in graphics, the label should just be deleted. The justification for "Affects" is not going to be obvious to most users.

Thanks for responding so quickly to my comment. The Inkscape package is an impressive work and I hope to see its continued development.

Tom

summary: - Verb "Affect" should be replaced with noun "Effect"
+ "Affect:" toolbar label should be renamed/removed
Changed in inkscape (Ubuntu):
importance: Undecided → Low
Alex Valavanis (valavanisalex) wrote :

Bumping this up to "Confirmed" as there appears to be consensus that the label text is incorrect. It also seems a bit strange that this button group is labeled while most others are not.

@developers - Any strong feelings about this label?

Changed in inkscape:
status: Opinion → Confirmed
Changed in inkscape (Ubuntu):
status: Opinion → Triaged
tags: removed: amd64 lucid
description: updated
su_v (suv-lp) wrote :

> Bumping this up to "Confirmed" as there appears to be consensus

Exclude me from the consensus please - I agree with Max (comment #3): the toggles are not 'effects' (like e.g. filter effects which can be applied to and removed from objects), they describe how objects are affected by transformations.

pir (p-rockett) wrote :

I agree with Tom McNickell: either i) remove it or ii) change it to "Effect". Retaining the label "Affect" makes no sense and looks very wrong to a native English speaker. Looking at the tooltips, these do seem to be "effects".

Peter

Alex Valavanis (valavanisalex) wrote :

The "Affect:" label is:
(a) Grammatically inconsistent... (all/most other toolbar labels are nouns)
(b) Sylistically inconsistent... (toolbar labels are pretty rare. The icons, tooltips and layout should speak for themselves)
(c) Uninformative... (what is affecting what?)
(d) Redundant... (the tooltips are far more informative)

However, "Effect" is incorrect too (see comment #11). I think the best bet is just to get rid of it!

jazzynico (jazzynico) on 2012-03-05
Changed in inkscape:
milestone: none → 0.49
status: Confirmed → Triaged
John Smith (john-smithi) wrote :

The label doesn't add anything useful for the user, since there is no real "grouping" that implies a group label.
Users have to read the tooltips to understand what each button does.

I vote the drop the label.

Alex Valavanis (valavanisalex) wrote :

I say go for it... I haven't heard any real opposition for getting rid of it!

jazzynico (jazzynico) wrote :

Patch in progress.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Label removed as of revision 11062.

Changed in inkscape:
status: In Progress → Fix Committed

It is now four years later. I recently discovered Inkscape, and have begun using it to edit SVG images. And this afternoon I was finally so annoyed by the "Affect" label that I reported it as a bug in need of fixing. I was soon notified that I was reporting a duplicate of this error, Bug #590686. And here I now am, reading over the text of the above messages.

The messages suggest that the error has been fixed. Well, boys and girls, it is still here. Inkscape 0.48.4 r9939. I am using Windows 7 on a 64 bit system. I am a native English speaker. I am a grammar nazi. And I am incredulous that this problem is apparently still being reproduced. WTF???

Hey, though: it's not like Adobe Illustrator CS6 isn't replete with its own stockpile of linguistic mishaps. Looks to me like nobody thinks it's important to have their software vetted by someone with a degree in English anymore before distributing it to the public. Adobe has been around long enough to know better. Christ, how can programmers still be making these kinds of mistakes? Doesn't anyone check their work? Did they all get a C in English??

(Can you hear me laughing? I am laughing here... Sort of.)

Sorry, not four years, only two. I read the date wrong. Who puts the year in front of the month and day??

Alvin Penner (apenner) wrote :

@Kirby, you might wish to consider reading the entire thread above, since there have been a number of very interesting points raised, indicating that the 'correct' answer is not entirely clear cut.

In any event, this has been fixed in the Inkscape trunk, which is the development version. The fix was committed to rev 11062, on March 8, 2012.

see: http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/11062

you can see the effects of the fix by downloading a development version from
http://inkscape.org/download/?lang=en/
or by waiting for the official release of 0.49

su_v (suv-lp) wrote :

> Well, boys and girls, it is still here. Inkscape 0.48.4 r9939. I am using Windows 7 on a 64 bit system.

Well, if you had taken the time you spent writing your latest comment and spent it instead on inspecting the information provided on the web page of the report, you would have realized that the state of this report is 'Fix Comitted' and _not_ 'Fix Released' - the next major release will ship without that label (0.49).

<off-topic>
> Who puts the year in front of the month and day??

The project 'Inkscape' is not maintaining nor developing the web interface to the bug tracker hosted by launchpad.net.
</off-topic>

Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions