Shift doesn't disable node snapping

Bug #588628 reported by prkos on 2010-06-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski

Bug Description

In Node tool when moving nodes they still snap when holding Shift while dragging. I tested snapping to nodes and to grid on 9456 on linux.

In 0.47 there is a bug when moving cusp nodes, if you press Shift while moving it drags out the handle instead if disabling snapping, although it seems to be fixed now. But disabling snapping of smooth nodes (in 0.47) works as expected so I guess at least partially this is a regression.

su_v (suv-lp) on 2010-06-02
tags: added: node-editing
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.47+devel r9469 on OS X 10.5.8

Somewhat related: same issue with disabling snapping while dragging node handles (in this case there's a conflict with interfering shortcut keys, but maybe it is the reason why the global shortcut to temporarily disabled snapping (<Shift>) doesn't work in the node tool at all?) - see the discussion in bug #538487.

Changed in inkscape:
status: New → Confirmed

This is indeed already discussed in the bug ~suv mentioned, so I will mark this as a duplicate.

su_v (suv-lp) on 2010-06-06
tags: added: shortcuts
su_v (suv-lp) wrote :

Reverting duplicate status (of bug #538487) to move the discussion about keyboard shortcuts in the node tool back here.

su_v (suv-lp) on 2010-06-23
Changed in inkscape:
importance: Undecided → Medium
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.48.1
Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

inkscape trunk: r9904
inkscape 0.48.x: r9724

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers