Eraser: eraser stroke is drawn after clicking canvas but doesn't erase.

Bug #588181 reported by Masato HASHIMOTO on 2010-06-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Adonis Papaderos

Bug Description

After clicking the canvas, eraser stroke is drawn but any objects are not erased.
After next click, drawing new eraser stroke is started.

Versions:
Inkscape trunk-r9459

su_v (suv-lp) on 2010-06-01
tags: added: eraser
su_v (suv-lp) wrote :

not reproduced with Inkscape 0.47+devel r9462 on OS X 10.5.8

Does it happen regardless of the object types you are trying to erase or subtract from? Did you test with default preferences (attach the faulty 'preferences.xml' if it works as expected with the default settings)? Or can you attach a sample file where the eraser fails as described?

Masato HASHIMOTO (hashimo) wrote :

@~suv

> Does it happen regardless of the object types you are trying to erase or subtract from?

Well, this issue happens just after stat-up inkscape, without any objects or any other operations.

> Did you test with default preferences

Also happens.

inkscape trunk -r9465 also happens.
Attached is a hardcopy of trajectory of the erser stroke from click.

My environment:
Arch Linux (x86_64)
gtk 2.20.1
gtkmm 2.20.3

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape 0.47 and revision 9433.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
su_v (suv-lp) wrote :

> this issue happens just after stat-up inkscape, without any
> objects or any other operations.

Do you mean the eraser tool is active (instead of the select tool) after launching Inkscape, without actually clicking its toolbox button? Could something outside Inkscape send the keyboard shortcut (Shift+E) to activate it?

The red line (which disappears as soon as you release the mouse button) is AFAIU normal when using the eraser both in 'Delete' and 'Cut out' mode, with or without any objects present.

su_v (suv-lp) wrote :

nevermind - I figured out what you mean.

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47 and 0.47+devel r9462 on OS X 10.5.8

while the eraser tool is active:
- click-dragging the left mouse button:
The tool works as expected and erases or cuts out form the touched objects
- click once with the left mouse button:
An inactive thin eraser path is being drawn on canvas, following the cursor movements.
When switching to a different tool and back to the eraser the red line is continued without any further interaction.
Only <esc> while the eraser tool is active (to defocuse (?) the canvas) seems to stop the line-drawing and it disappears.

jazzynico (jazzynico) wrote :

Tested successfully on Ubuntu 10.04, and committed in the trunk, revision 9918.
No regression found so far.

Thanks for this patch!

Changed in inkscape:
assignee: nobody → Adonis Papaderos (ado-papas)
milestone: none → 0.49
status: Confirmed → Fix Committed
Changed in inkscape:
milestone: 0.49 → 0.48.1
jazzynico (jazzynico) wrote :

Committed in the 0.48.x branch, revision 9733.

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments