localization bug in internal extensions

Bug #586063 reported by v1nce on 2010-05-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico

Bug Description

Hi,

I think there's a bug in drop-shadow.h (and possibly lots of code).
g_strdup_printf(...%f...%f,,,...) is "localization sensitive".
So, with FR localization, float numbers are written x,y instead of x.y

to reproduce bug :
Get a FR computer (or set your locale ?)
Draw a rect.
Filters /shadows/drop shadow (or any filter with an UI to input fields)
Look at the numbers in the xml (stddeviation or color matrix), they are spelled x,y instead of x.y

If you design your own filter using the filter designer, then
you NEED to enter the numbers as x,y [which is bad IMHO see 586059] but they will be correctly stored in the xml

Related branches

su_v (suv-lp) on 2010-05-26
tags: added: filters-svg ui
jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 10.04, Inkscape revision 9454.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
jazzynico (jazzynico) wrote :

> I think there's a bug in drop-shadow.h

Yes.

> (and possibly lots of code).

I don't think so, because filters extensions are very specific. But don't hesitate to tell us if you find another related issue elsewhere.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
v1nce (vincent-pennec) wrote :

What would be the fix ? I tried %F instead of %f but it seems to have no effect.

I listed possible other files affected in bug 586104

jazzynico (jazzynico) wrote :

Currently working on drop-shadow, drop-glow and grid internal filters.

Changed in inkscape:
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

... internal "extensions".

jazzynico (jazzynico) wrote :

drop-shadow.h, grid.cpp and snow.h fixed in bzr revision 9456.
Tested on Ubuntu 10.04, C and fr locales.

Closing this report "Fix committed". I'll investigate the other cases in Bug #586104.

summary: - localization bug in drop-shadow.h
+ localization bug in internal extensions
Changed in inkscape:
milestone: none → 0.48
status: In Progress → Fix Committed
jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers