Axonometric grid rotated

Bug #583141 reported by prkos on 2010-05-20
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Johan Engelen

Bug Description

The 0 angle in axonometric grid isn't perfectly horizontal and 90 angle isn't perfectly vertical.

When I pull out a horizontal guide the angle value is automatically changed to 1.
If I have the 90 angle, vertical guide sets it to 89.

Tested on 9425 and 0.47.

prkos (prkos) on 2010-05-20
description: updated
prkos (prkos) on 2010-05-20
tags: added: grids
su_v (suv-lp) wrote :

not reproduced with Inkscape 0.47 and 0.47+devel r9435 on OS X 10.5.8 using
- default (new) preferences file
- default A4 template (Inkscape ui language: System default / en_US.UTF-8)
- new default axonometric grid (Document Properties)

su_v (suv-lp) wrote :

sorry - I missed the important step:
> The 0 angle in axonometric grid isn't perfectly horizontal
> and 90 angle isn't perfectly vertical.

reproduced with Inkscape 0.47 and 0.47+devel r9433 on OS X 10.5.8

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Johan Engelen (johanengelen) wrote :

90 degree angle would result in impossibly many grid lines (just see what setting it to 80 looks like), but indeed 0 degree should work and bothered me too. It was disabled in the code because it caused troubles/crashes. I just fixed this. r11830

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.49
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

The fix (or the cleanup afterwards) apparently breaks building on linux (e.g. Ubuntu build bots) and on OS X:

Error from failed Ubuntu Quantal build [1]:

In file included from ./ui/widget/labelled.h:14:0,
                 from ./ui/widget/scalar.h:15,
                 from ./ui/widget/registered-widget.h:15,
                 from display/canvas-axonomgrid.cpp:20:
/usr/include/gtkmm-2.4/gtkmm/box.h:105:1: error: expected class-name before '{' token
/usr/include/gtkmm-2.4/gtkmm/box.h:112:10: error: '_GtkBoxChild' does not name a type
/usr/include/gtkmm-2.4/gtkmm/box.h:114:16: error: '_GtkBoxChild' does not name a type
/usr/include/gtkmm-2.4/gtkmm/box.h: In member function 'guint16 Gtk::Box_Helpers::Child::get_padding() const':
/usr/include/gtkmm-2.4/gtkmm/box.h:118:55: error: 'gobj' was not declared in this scope
/usr/include/gtkmm-2.4/gtkmm/box.h: In member function 'bool Gtk::Box_Helpers::Child::get_expand() const':
/usr/include/gtkmm-2.4/gtkmm/box.h:119:55: error: 'gobj' was not declared in this scope
/usr/include/gtkmm-2.4/gtkmm/box.h: In member function 'bool Gtk::Box_Helpers::Child::get_fill() const':
/usr/include/gtkmm-2.4/gtkmm/box.h:120:55: error: 'gobj' was not declared in this scope
/usr/include/gtkmm-2.4/gtkmm/box.h: In member function 'bool Gtk::Box_Helpers::Child::get_pack() const':
/usr/include/gtkmm-2.4/gtkmm/box.h:121:55: error: 'gobj' was not declared in this scope
/usr/include/gtkmm-2.4/gtkmm/box.h: In member function 'GtkBox* Gtk::Box_Helpers::Child::parent()':
/usr/include/gtkmm-2.4/gtkmm/box.h:130:52: error: 'gobj' was not declared in this scope
make[4]: *** [display/canvas-axonomgrid.o] Error 1
make[4]: Leaving directory `/build/buildd/inkscape-trunk-0.48+devel+11832+32~quantal1/src'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/build/buildd/inkscape-trunk-0.48+devel+11832+32~quantal1/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/inkscape-trunk-0.48+devel+11832+32~quantal1'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/inkscape-trunk-0.48+devel+11832+32~quantal1'

[1] <https://launchpadlibrarian.net/121260324/buildlog_ubuntu-quantal-amd64.inkscape-trunk_1%3A0.48%2Bdevel%2B11832%2B32~quantal1_FAILEDTOBUILD.txt.gz>

su_v (suv-lp) wrote :

Build succeeds (on OS X, with gtkmm 2.24.2, Apple's llvm-gcc-4.2) after reverting the last two revisions for 'canvas-axonomgrid.cpp':
$ bzr revert -r 11830 src/display/canvas-axonomgrid.cpp

su_v (suv-lp) wrote :
Alex Valavanis (valavanisalex) wrote :

Unfortunately, this kind of build error will probably keep cropping up for a while. It's because GTK+ and a few of the gtkmm headers don't play nicely together when the "GTK_DISABLE_DEPRECATED" flag is defined.

The solution is to ensure that the offending <gtkmm/*.h> headers are included *before* <gtk/gtk.h>.

Bryce Harrington (bryce) on 2015-02-23
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions