(inkscape:1815): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed on Start

Bug #576852 reported by Dídac Rios on 2010-05-07
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Low
Inkscape
Undecided
Unassigned
gtk+2.0 (Debian)
Fix Released
Unknown
gtk+2.0 (Ubuntu)
Low
Unassigned
Lucid
Low
Sebastien Bacher

Bug Description

On start, appears constantly on the shell

(inkscape:1815): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed

But seems that Inkscape runs correctly, no problems apparently

su_v (suv-lp) wrote :

This is an upstream bug in Gnome/GTK+:
616851 - Gtk-CRITICAL **: gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed
<https://bugzilla.gnome.org/show_bug.cgi?id=616851>

tags: added: ui
su_v (suv-lp) wrote :

fixed in GTK+ 2.21.0 (latest unstable release)
<http://mail.gnome.org/archives/gtk-list/2010-May/msg00024.html>

su_v (suv-lp) wrote :

fixed in GTK+ 2.20.1 too (bug fix release in the 2.20 series - Sun, 02 May 2010)
<http://mail.gnome.org/archives/gtk-list/2010-May/msg00000.html>

su_v (suv-lp) wrote :

The GTK+ bug apparently is *not* fixed in GTK+ 2.20.1 - after upgrading to gtk2 @2.20.1_0+x11 (MacPorts) I see the same error messages (Inkscape 0.47+devel r9424 on OS X 10.5.8).

su_v (suv-lp) wrote :

Rebuilding gtk2 2.20.1 with the patch [1] mentioned in comment #11 <https://bugzilla.gnome.org/show_bug.cgi?id=616851#c11> fixes the bug causing these console messages in Inkscape.

[1] http://git.gnome.org/browse/gtk+/patch/?id=ba3e997daea267b100988ecd7c6d0767c334dfbc

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Changed in gtk+2.0 (Ubuntu Lucid):
importance: Undecided → Low
status: New → Fix Committed
assignee: nobody → Sebastien Bacher (seb128)
Changed in inkscape:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

debdiff without the translation, autotools, etc noise

su_v (suv-lp) wrote :

[osx packaging] Ticket filed in MacPorts for including the patch in gtk2 @2.20.1:
<http://trac.macports.org/ticket/24948>

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Pedro Villavicencio (pedro) wrote :

Been using the proposed package for a few days now and did not noticed any regression so far, Also i can also confirm that it does fixes the issue of the Gtk-Critical message. Marking this as verification done, thanks all.

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

maverick has a newer version

Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.20.1-0ubuntu1

---------------
gtk+2.0 (2.20.1-0ubuntu1) lucid-proposed; urgency=low

  * New upstream version:
    - Support Tracker 0.8 in the filechooser search
    - Bug fixes:
    615028 gdk/x11/gdkdnd-x11.c missing Xutil.h
    614099 GtkFileSystemModel may causes crash in g_file_get_child
    615999 Gail doesn't send state-changed events for ATK_STATE_ENABLED
    614894 Add heuristic for pre XRandR 1.3 drivers
    613988 Compile error on DirectFB backend due to missing...
    560147 GtkBuilder docs should say what GErrors they throw
    615128 gdk monitor order does not seem to be correct
    614971 Initialize search engines on demand
    613887 Misprint in the description of gtk_cell_view_new_with_text
    615853 BadMatch when pressing keyboard volume keys...
    615000 gtk_builder_value_from_string_type() returns FALSE without...
    614540 configure wants gio-unix on all platform
    613974 GtkToolItemGroup devides by 0 when allocating space...
    557689 In 'select folder' action, filechooser doesn't work when...
    616851 gtk_misc_set_alignment: assertion `GTK_IS_MISC (misc)' failed
    402349 FileChooser's default directory is not "active"
    64bit issue with the ICC profile support in the PNG loader
    Missing break statement in gtk_tool_item_group_set_property
    Missing default events in gtk_tool_item_group_realize
    - Updated translations
  * debian/patches/003_gdk.pc_privates.patch:
    - updated for the new version
  * debian/patches/064_initial_fileselector_select.patch,
    debian/patches/090_directfb-map-virtual-modifiers.patch:
    - the change is in the new version
  * debian/patches/070_mandatory-relibtoolize.patch:
    - new version update
  * debian/patches/092_git_change_no_gtkmisc_warning.patch:
    - git change to really fix the gtkmisc warnings issue (lp: #576852)
 -- Sebastien Bacher <email address hidden> Tue, 18 May 2010 14:18:59 +0200

Changed in gtk+2.0 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in gtk:
importance: Unknown → Low
status: Unknown → Fix Released
Changed in gtk+2.0 (Debian):
status: Unknown → Fix Released
Alex Valavanis (valavanisalex) wrote :

It turns out that this bug was really fixed upstream in gtk+2.0 version 2.21.5 (see upstream changelog!).

The fix made it into Ubuntu:

gtk+2.0 (2.21.5-1ubuntu1) maverick; urgency=low

  * Merge with Debian experimental, Ubuntu changes:
  * debian/control.in:
    - Add introspection build-depends
    - Add Vcs-Bzr link
    - Add gir1.0-gtk-2.0 package
    - libgtk2.0-dev replaces gir-repository-dev
    - Conflict with appmenu-gtk (<< 0.1.3) to prevent menu proxy breakage
  * debian/rules:
    - Build with --enable-introspection
    - Add gir1.0-gtk-2.0 package to BINARY_ARCH_PKGS
    - Add dh_girepository call
    - Disable devhelp files
  * debian/dh_gtkmodules.in:
    - Remove obsolete script content
  * debian/libgtk2.0-0.symbols:
    - Add Ubuntu specific symbols
  * debian/libgtk2.0-dev.install.in:
    - Add gir files
  * debian/libgtk2.0-doc.install.in
    - Disable devhelp files
  * debian/gir1.0-gtk-2.0.install.in
    - Introspection package
  * debian/patches/043_menu_proxy.patch
    - Add GtkMenuProxy support for remoting menus.
  * debian/patches/062_dnd_menubar.patch:
    - Allow click on menubars for dnd
  * debian/patches/063_treeview_almost_fixed.patch:
    - Add an ubuntu-almost-fixed-height-mode property, (required for
      software-center)
  * debian/patches/071_no_offscreen_widgets_grabbing.patch:
    - Don't let offscreen widgets do grabbing
  * debian/patches/072_indicator_menu_update.patch:
    - change by Cody Russell to send an update event on menu changes,
      should make the bluetooth indicator refresh correctly
  * debian/patches/091_bugzilla_tooltip_refresh.patch:
    - Upstream bugzilla change to have better looking tooltips the gtk theme
      need to set "new-tooltip-style" to use those
  * debian/watch:
    - Watch for unstable versions
 -- Robert Ancell <email address hidden> Thu, 22 Jul 2010 21:41:30 +0200

Changed in gtk+2.0 (Debian):
status: Fix Released → Confirmed
Changed in gtk+2.0 (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.