after resizing document beyond the default A4 page size, moving connectors becomes buggy

Bug #576815 reported by Charles on 2010-05-07
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I am using Inkscape 0.47 on Ubuntu 10.04.
This bug can be reproduced:

Draw a straight line with "Create Diagram Connector".
Go to File->Document Properties and resize the page to something different from A4.
Move the line by dragging it or try to change the X or Y position directly from the textboxes. The line will not move to the desired location and would probably disappear from the view.

I have tried the nightly built developer version on May 6, 2010 and the bug is still present.

su_v (suv-lp) on 2010-05-07
tags: added: connectors
su_v (suv-lp) on 2010-05-07
tags: added: transformations
su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9400 on OS X 10.5.8

Duplicate, has the same underlying issue as many other reports about connector problems:
connectors don't handle parent transforms well (connectors inside transformed groups can get misplaced either in preview, when adding the transform, when ungrouping the transformed parent group, when moving the connector after changing the parent transformation etc.). Changing the page size or orientation adds a transform attribute to the top-level layers (which are just groups).

bug #552289 “Ungrouping objects changes position of arrow lines”
bug #533897 “Incorrect preview when editing a connector within a group that has been transformed”
bug #479638 “file gets mangled due to Object->UnGroup”
bug #479577 “Cannot move (drag) an object”
bug #479553 “Moving shape with connectors, connectors go wild”
bug #429926 “Node Connectors in Wrong Positions After Document Resize”
bug #267679 “malfunction of connectors after 'fit page to selection'”
bug #168360 “Connectors between groups act weird”
… and likely others I have missed.

Changed in inkscape:
status: New → Confirmed
summary: - after resizing document beyond the default A4 page size, moving line
- objects becomes buggy
+ after resizing document beyond the default A4 page size, moving
+ connectors becomes buggy
Changed in inkscape:
importance: Undecided → Medium
su_v (suv-lp) wrote :

No longer reproduced in Inkscape 0.48+devel r9989 on OS X 10.5.8

(fixed with r9988)

su_v (suv-lp) on 2010-12-29
Changed in inkscape:
milestone: none → 0.48.1
status: Confirmed → Fix Committed
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers