Main window appears in odd places when opening regular SVG file

Bug #568867 reported by Alfonse on 2010-04-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Patrick Storz
0.92.x
Low
Patrick Storz

Bug Description

I have set the Window preferences to "Remember and use last window's geometry." As I understand it, this means that Inkscape should open itself to the same place regardless of what file I open, yes?

The problem is that Inkscape does not do this when it is opening a hand-generated SVG file. Or any SVG file that does not have Inkscape's special markup in it. The window will appear in the upper-left corner regardless. The only time this is not true is if Inkscape was maximized when it was last closed, in which case it will be maximized, as expected.

Also, if you have the Windows taskbar on the left or top of the screen, then the new Inkscape window will appear partially behind the taskbar. It should appear beside the taskbar, in the upper-left corner of the desktop that is not behind the taskbar.

Also, I've noticed that the Inkscape window flashes a lot when loading these files. That might be part of the problem.

To reproduce:

1: Change Inkscape's Window preferences to "Remember and use last window's geometry."

2: Unmaximize Inkscape and close all Inkscape windows.

3: Create an SVG file by hand in a text editor. A simple line is sufficient. It should have none of Inkscape's special markup.

4: Move your Windows taskbar to the left side of the screen, rather than docked at the bottom.

5: Open the SVG file in Inkscape.

6: Notice that the window does not conform to the previously closed window's position. Also, notice that a portion of the window is under the task bar, rather than respecting the reduced desktop space due to the task bar's location.

Inkscape version 0.46, Windows 7 Pro x64 and Windows Vista Pro x64

Tags: ui Edit Tag help
su_v (suv-lp) on 2010-04-23
tags: added: ui
Zian (zian-choy) wrote :

This problem also happens with a fresh install of Inkscape 64-bit edition on Windows 7 SP1 64-bit edition EN-US.

su_v (suv-lp) on 2015-10-16
tags: added: win32
tags: removed: win32
su_v (suv-lp) wrote :

On OS X 10.7.5:
- reproduced with Inkscape 0.48.5
- not reproduced with Inkscape 0.91 (last used Window geometry is also used for "regular SVG" files and other vector-based file formats). Note that with 0.91, you need to set 'Default window size' to 'Small', too (see also bug #1190828).

Does the reported issue persist on Windows with Inkscape 0.91?

Changed in inkscape:
importance: Undecided → Low
status: New → Incomplete
uwestoehr (uwestoehr) wrote :

> Does the reported issue persist on Windows with Inkscape 0.91?

Yes, I can also reproduce this bug with Inkscape 0.92. The bug is that Inkscape's main window is always opened at the upper left screen corner - Always, even if there is the Windows' task bar.

That Inkscape does not store the window position is now reported as separate bug: #1654464

uwestoehr (uwestoehr) wrote :

Now correct: That Inkscape does not store the window position is now reported as separate bug #1654464

Patrick Storz (ede123) wrote :

This bug should be fixed in r15507
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15507

Let me know if any issues remain.

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
jazzynico (jazzynico) on 2017-02-11
Changed in inkscape:
status: Incomplete → Fix Committed
milestone: none → 0.93
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers