extension slicer let inkscape crash

Bug #554301 reported by uwesch on 2010-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

tested with windows 7 and R9279

1. Draw a shape (i.e. ellipse)
2. use the extension --> Internet --> Slicer --> Create a slicer rectangle...
3. In the dialog change to the HTML-Tab
4. click on Layout disposition
5. click on Position anchor
6. change to GIF-Tab
7. change to JPG-Tab
8. click in the field 'background color'
9. click in the field 'Force Dimension'
10. Click on Format 'PNG'
11. Click in the field 'name'
12. Click on "Close'

The result is, that inkscape crashes completely because of an internal error.

su_v (suv-lp) on 2010-04-03
tags: added: crash extensions-plugins
Changed in inkscape:
importance: Undecided → High
Alvin Penner (apenner) wrote :

confirmed on Windows XP, bzr rev 9263, exit message is:

(inkscape.exe:2424): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

Emergency save activated!

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :

Aurelio, could you please take a look?

Changed in inkscape:
assignee: nobody → Aurium (aurium)
jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.1.
Not reproduced with 0.48.2, 0.48.3.1 and trunk revision 11562.

Changed in inkscape:
assignee: Aurium (aurium) → nobody
milestone: none → 0.48.2
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers