Reverting saved as a "Lock layer" action

Bug #552541 reported by Victor Engmark on 2010-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

This was not reproducible on an empty SVG image, but on the attached file. How to reproduce:
1. Open the file.
2. Revert the file.

After reverting, the action "Undo: Lock layer" shows up in the Edit menu. This should not be there. Also, because of this, when trying to close the file afterwards (with no changes after reverting) Inkscape protests that changes will be lost.

Using Inkscape 0.47.

Victor Engmark (victor-engmark) wrote :
su_v (suv-lp) wrote :

reproduced with Inkscape 0.47 and 0.47+devel r9261 on OS X 10.5.8

The entry in the undo history happens when opening a drawing (not only when reverting) if the 'current layer' - a setting that is stored in the document - is locked.

I guess bug #552535 “Reverting is unaware of image changes” is about the same issue and can be marked a duplicate of this one?

tags: added: layers undo
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Victor Engmark (victor-engmark) wrote :

Thanks for the quick reply. It doesn't seem like the same issue, although they were both discovered when using Revert.

su_v (suv-lp) wrote :

related to bug #251328 “Layer visibility and locking changes should not appear in Undo History”
<https://bugs.launchpad.net/inkscape/+bug/251328>

su_v (suv-lp) wrote :

reproduced with Inkscape 0.48.0 and 0.48.1,
not reproduced with Inkscape 0.48.2, 0.48.3.1 and 0.48+devel r11297

Changed in inkscape:
milestone: none → 0.48.2
status: Confirmed → Fix Released
su_v (suv-lp) wrote :

Probably fixed with the changes in r10113 for bug #249035.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments