No color profiles listed in CMS tab of Document Properties

Bug #551162 reported by Alexandre Prokoudine on 2010-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jon A. Cruz

Bug Description

Not a single ICC profile is listed in a combobox in CMS tab of Document Properties dialog. I do have a bunch of color profiles in correct system folders *and* they are picked by GNOME Color Manager, so this is not location issue on my side. I'm running Ubuntu 9.10 and few days old Inkscape. I've been seing this since 0.47, for months.

su_v (suv-lp) wrote :

not reproduced with Inkscape 0.47 and 0.47+devel on OS X 10.5.8

tags: added: color ui
Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
Jon A. Cruz (jon-joncruz) wrote :

Can you check that the files are located in a directory that Inkscape lists in the set on the preferences dialog? Also that they are standard files and do not have symlinks in their paths, etc.?

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed

Okay, cleaning up preferences.xml seems to have fixed that. Just one minor notice: names of the files in the combobox are centered, no aligned to the left the way they should be.

This is badly broken in 0.48.

No color profiles folder is used by default on Linux, since no paths for them is used.

User config: /home/avp/.config
User data: /home/avp/.local/share
User cache: /home/avp/.cache
System config: /etc/xdg/xdg-gnome
  /etc/xdg
System data: /usr/share/gnome
  /usr/local/share/
  /usr/share/
PIXMAP: /usr/share/inkscape/icons
DATA: /usr/share
UI: /usr/share/inkscape/ui
Icon theme: /home/avp/.icons
  /home/avp/.local/share/icons
  /usr/share/gnome/icons
  /usr/local/share/icons
  /usr/share/icons
  /usr/share/gnome/pixmaps
  /usr/local/share/pixmaps
  /usr/share/pixmaps
  /home/avp/.local/share/inkscape/icons
  /usr/share/gnome/inkscape/icons
  /usr/local/share/inkscape/icons
  /usr/share/inkscape/icons
  /home/avp/.config/inkscape/icons
  /usr/share/inkscape/icons

su_v (suv-lp) wrote :

> This is badly broken in 0.48.
Can't let this stay without further comment ;)

From the tooltip of 'Display profiles' in prokoudine's
 'Inkscape Preferences > Color Management > Display Adjustment':

|22:44| < prokoudine> /usr/(local/)share/icc - 1 and 2
|22:45| < prokoudine> /usr/share/gnome/icc, for some reason -- 3
|22:45| < prokoudine> /home/avp/.local/share/color/icc, which is completely bogus -- 4

1) User installed color profiles:
As discussed on irc, the main issue in this case seems that profiles installed into '~/.color/icc' are not loaded by Inkscape, instead it is searching in '~/.local/share/color/icc' (following the OpenICC recommendation).

2) System-wide color profiles:
|22:50| < prokoudine> that still doesn't explain why inkscape doesn't show profiles like Fogra that are in the system directory

Changed in inkscape:
status: Confirmed → In Progress
Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

 trunk: r9834
0.48.x: r9689

Changed in inkscape:
milestone: none → 0.48.1
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers