Mac OS X AQUA: clipboard doesnt work

Bug #546934 reported by Wolf on 2010-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

The Mac OS X clipboard doesnt work with inkscape 0.47 AQUA, devel-r9101, OS 10.4.11 - neither for importing, not for exporting files.

su_v (suv-lp) wrote :

I don't understand "neither for importing, not for exporting files" - do you mean drag&drop a bitmap image or SVG file from the finder or selecting and copying a bitmap image in e.g. your web browser and pasting the clipboard contents into Inkscape?

Could you detail the steps, the expected result and what actually happens? What does the Inkscape status line say? Any related console messages?

tags: added: clipboard gtk-osx osx
Wolf (drechsel) wrote :

"Export" means: I select an object, hit ctrl-c, switch to another application (tried preview.app and textedit.app) and try to paste. Nothing happens. ("New from clipboard" in preview is gray, "Content of clipboard" in the Finder says: "Content of clipboard: unknown".

"Import" means vice - copied a piece of pdf from previw.app, tried to paste into inkscape. Nothing happens.

No messages at, neither in console.log, nor if I launch inkscape from the terminal, nor in inkscape status line.

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r10101 on OS X 10.5.8 (i386), gtk2 @2.22.1_1+no_x11+quartz

AFAIK, upstream bug in Gtk+ (not yet implemented).

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
su_v (suv-lp) wrote :

Copying objects between Inkscape windows OTOH does work.

su_v (suv-lp) wrote :

Still present in GTK+/Quartz 2.24.10

su_v (suv-lp) wrote :

Related upstream report:
- 692123 - Exchanging arbitrary items with the Mac OS X system clipboard
  <https://bugzilla.gnome.org/show_bug.cgi?id=692123>

su_v (suv-lp) on 2017-01-12
tags: added: gtk-quartz
removed: gtk-osx
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.