Node editing causes segmentation fault

Bug #544599 reported by adamorjames on 2010-03-22
62
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

Inkscape 0.47+devel r9214 custom
Linux (Arch Linux) 2.6.32-ARCH

Reproduce:

Create two nodes left of the bottom right node.
Drag them.
Undo.

adamorjames (adamorjames) wrote :
su_v (suv-lp) on 2010-03-22
tags: added: crash node-editing
removed: nodes segfault
Changed in inkscape:
importance: Undecided → High
adamorjames (adamorjames) wrote :
description: updated
su_v (suv-lp) wrote :

not reproduced with Inkscape 0.47+devel r9222 on OS X 10.5.8 (default settings)

ScislaC (scislac) wrote :

Not reproduced with 9218 on Ubuntu Lucid... just finished compiling 9222 right now and can't reproduce w/ that build either.

This could be one of those fluke "building Inkscape on Arch" things that seems to pop up occasionally. (translation, a bug that only affects Arch users, and temporarily as they usually get libs or whatever else fixed)

adamorjames (adamorjames) wrote :

Produced with same system using 9222.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.48
Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :

Not reproduced on Windows XP, Inkscape rev 9676.

@Alex: on which OS and Inkscape revision did you reproduce this issue?

ro-ee (alexander-roalter) wrote :
ro-ee (alexander-roalter) wrote :

Don't know if it is the same, but if I create a rectangle, convert it to paths and double-click on the path to add more nodes, and then move the nodes around, i occasionally get either inkscape crashing (with no but report) or some times with bug report.

my previous entry is the bug report from inkscape.

su_v (suv-lp) wrote :

@ro-ee - can you provide information about your platform and Inkscape version?

su_v (suv-lp) wrote :

System info for crash report in comment #7 (from bug #624277):
- OpenSuse 11.2
- Inkscape 0.48+devel r9723
- GTK+ 2.18.3

Alex Valavanis (valavanisalex) wrote :

I'm sorry, I can't remember which version I was using when I changed the status. I can't reproduce this on Ubuntu Maverick using 0.48.

@adamorjames - does this still affect you with Inkscape 0.48?

I've unassigned this bug, until we figure out whether it is reproducible. The 0.48 milestone has passed, in any case.

Changed in inkscape:
assignee: Krzysztof Kosinski (tweenk) → nobody
milestone: 0.48 → none
status: Confirmed → Incomplete
su_v (suv-lp) wrote :

related or duplicate report:
Bug #664831 “Undo after drag path causes inkscape to crash”:
<https://bugs.launchpad.net/inkscape/+bug/664831>

Crash in bug #664831 -- reproduced with Inkscape r9841 built on osx without debug option ('-g') -- has the same backtrace as in comment #1 and #7 here (bug #544599): crashes in Inkscape::UI::CurveDragPoint::_getTip(unsigned int)

su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r9841 from modevia on OS X 10.5.8 with file attached in comment #2,
but so far not reproduced with local debug builds.

Changed in inkscape:
status: Incomplete → Confirmed
su_v (suv-lp) wrote :

Since it has be reproduced on different systems (bug #664831: Ubuntu, OS X; bug #664831: ArchLinux, OpenSuse, OS X), reverting assignment change (see comment #11).

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
Alex Valavanis (valavanisalex) wrote :

I finally managed to reproduce in inkscape_0.48.0-1ubuntu2 on natty but I had to try various different moves of the nodes before the crash occurred.

Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Krzysztof Kosinski (tweenk) wrote :

Looks like the crash actually occurs when you try to drag an orphaned curve dragpoint that is created when you undo the creation of certain nodes. I added a call to hide the dragpoint before processing an undo operation, which should fix it.

Changed in inkscape:
milestone: none → 0.48.1
status: Triaged → Fix Committed
Krzysztof Kosinski (tweenk) wrote :

Should be fixed in 9906.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.1-0ubuntu1

---------------
inkscape (0.48.1-0ubuntu1) natty; urgency=low

  * New upstream version (LP: #710619). Fixes several Ubuntu bugs:
    - Node editing causes segmentation fault (LP: #544599)
    - Cursor position markers are not cleared from rulers (LP: #627134)
    - Crashes when opening document properties (LP: #658055)
    - Export to XCF error with default template (LP: #485032)
    - Editing a connector in a transformed group returns it to original
      position (LP: #533897)
    - Ungrouping objects changes position of arrow lines (LP: #552289)
    - Will not save XCF file (LP: #642417)
    - XCF export fails when exporting from unsaved document (LP: #650890)
  * Drop all patches: Applied upstream
  * debian/rules: Disable chmod on debian/patches/* in clean rule (no patches used)
 -- Alexander Valavanis <email address hidden> Tue, 01 Feb 2011 12:53:34 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
su_v (suv-lp) on 2011-04-05
tags: added: undo
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers