constrained node-dragging with <Ctrl> broken when snapping enabled

Bug #539995 reported by su_v on 2010-03-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Krzysztof Kosinski

Bug Description

Moving selected nodes in either the horizontal or vertical direction with 'Ctrl+Left Mouse Drag' in the node tool is broken when global snapping is enabled: The snap indicator 'Cusp node to constraint' is shown and the node either seems stuck (cannot be dragged at all) or jumps to an arbitrary location.

confirmed with 0.47+devel r9195 on OS X 10.5.8

testing older revisions:
 reproduced with r9105
 not reproduced with r9104

su_v (suv-lp) wrote :

Diederik - could you take a look at this?

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)

One of the changes made in that revision was on Krzysztof's request, because it would allow him to implement snapping in his new node editor with less code ("2) Always apply the constraint when asking for a constrained snap"). He also asked for instructions on how to implement snapping properly, so probably he's probably already working on this.

Krzysztof, what's the status? Finished your exams ;-) ?

LucaDC (dicappello) wrote :

I noticed that the node is moving correctly, actually, but _very_ slowly.
If you "shake" the mouse around some position, the node moves there after a while, as it needed to be "convinced".

Regards.

Krzysztof Kosinski (tweenk) wrote :

I can't reproduce this issue. In fact I explicitly changed some code to fix it in 9192 (I noticed such behavior before). Are you 100% sure it happens in the latest trunk? What are the exact steps (e.g. snap settings, grid status, etc.) needed to trigger this behavior?

su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9197

sorry, the only detail I forgot to verify: snap delay is set to 0 with otherwise default, unchanged settings.

Krzysztof Kosinski (tweenk) wrote :

Fixed in 9200

Changed in inkscape:
assignee: Diederik van Lierop (mail-diedenrezi) → Krzysztof Kosinski (tweenk)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers