Opposite symmetric node handle does not snap to grid

Bug #538487 reported by Thomas ten Cate on 2010-03-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Krzysztof Kosinski

Bug Description

Using Inkscape 0.47 on Windows 7 Professional 64-bits.

When editing a path, node handles will snap to the grid as expected. However, when a node is set to Symmetric, the opposite handle will not snap to the grid, making the node (slightly) asymmetric.

Steps to reproduce:
0. To best observe the effect, set the snapping delay to 0 in Preferences.
1. Create a new document.
2. Add a grid, and ensure that snapping is enabled for it.
3. Create a curve with the Bezier tool: click, drag, click, Enter.
4. Select the middle node with the node editing tool.
5. Click the Symmetric button in the toolbar. The handles will be adjusted to make them symmetric.
6. Drag one of the handles and let it snap to the grid.

Expected result: the handle (call this O) opposite the one I'm dragging (call this D) should remain exactly opposite to O, and at the same distance from the node itself (call this N).

Actual result: O does remain exactly opposite D, but its distance to N varies smoothly with my mouse movements. It is as though O's distance is computed from the position of D *before* snapping is applied to D's position.

Related branches

su_v (suv-lp) on 2010-03-13
tags: added: node-editing
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
Changed in inkscape:
status: New → Confirmed
importance: Undecided → Low
status: Confirmed → In Progress
Changed in inkscape:
status: In Progress → Fix Committed
milestone: none → 0.48
su_v (suv-lp) wrote :

fix confirmed with Inkscape 0.47+devel r9192 on OS X 10.5.8

@Krzysztof - thx a lot for implementing handle snapping in the new node tool :)

nitpicking: in 0.47 <SHIFT> allows to temporarily disable snapping (to grid) while dragging a handle - would it be hard to add this shortcut back as well?

Krzysztof Kosinski (tweenk) wrote :

Shift is already taken - it's used for rotating two handles of a cusp node at once.

Krzysztof Kosinski (tweenk) wrote :

To be clear, the aforementioned use of Shift was also present in the old node tool. I guess we need to choose which of the features is more important, otherwise they will interfere with each other; or I can re-add the Shift modifier only for non-cusp nodes or cusp nodes without a second handle (but it would be confusing).

su_v (suv-lp) wrote :

Indeed, the two shortcuts already interfere in the old node tool of 0.47. Maybe it's better to leave Shift for rotating two handles together only and - if needed - use the global 'Enable snapping' toggle on the snapping toolbar, though it is less convenient imho. Unfortunately the keyboard shortcut '%' (ToggleSnapGlobal) can't be used while dragging the handle.

Pander (pander) wrote :

While SHIFT is normally used for grid snapping, I would like to suggest the following implementation for changing handles:
- CTRL to snap angle
- ALT to lock length
- CTRL+ALT rotate both handles
- SHIRT (un)snap to grid
When handles by default snap to grid, the SHIFT should temporarily disable snapping to grid and vice versa. Some users would prefer default snapping of handles, others not. I do not have a preference but will need an easy way to switch between the two modes.

I would also suggest that the grid definition should offer "snap handles to grid" as an extra option with a sane default value.

Implementing it in this way will cater to all, be backwards compatible and in a way follow conventions within Inkscape.

prkos (prkos) wrote :

You can't use CTRL+ALT for a third option because of the case when you need to both snap to an angle and lock handle length.

I also vote for Shift to disable snapping.

Maybe the shortcut for rotating both cusp handles at once should be something with a "V" because that resembles the handles position. Shift+V?

This is not easily solved, because there are simply too little key modifiers available. Many tools defined their own modifiers for various reasons. The only way to try to resolve this situation is to make an overview of all tools and all modifiers, propose new priorities, and discuss this on the mailing list.

su_v (suv-lp) wrote :

I propose to revert the duplicate status of bug #588628 and move the discussion about alternative shortcut combinations for the node tool there, since this bug (#538487) as reported ("Opposite symmetric node handle does not snap to grid") has been fixed in r9192. (Yes, I should have filed a separate report right from the beginning instead of adding a comment here (#1)).

jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers