object to path and stroke to path buttons missing from node tool control bar

Bug #534045 reported by Kattekrab on 2010-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Jon A. Cruz

Bug Description

The icon buttons for 'Object to path' and 'Stroke to path' are missing from the node tool control bar. I found an old screenshot which shows the icons in place after the 'Make selected segments curves' button. See attached.

Can someone please put them back?

Kattekrab (donna) wrote :

Icons are still in place in BZR rev no. 8953 but gone in 9104

Jon A. Cruz (jon-joncruz) wrote :

In rev 8977 the toolbar items were explicitly commented out for some reason.

Changed in inkscape:
status: New → Confirmed
importance: Undecided → High
ScislaC (scislac) on 2010-03-07
Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
Changed in inkscape:
assignee: Krzysztof Kosinski (tweenk) → Jon A. Cruz (jon-joncruz)
Changed in inkscape:
milestone: none → 0.48
status: Confirmed → Fix Committed
Kattekrab (donna) on 2010-03-07
description: updated
Krzysztof Kosinski (tweenk) wrote :

Those commands are already available from Path menu. There is no point in duplicating them on the toolbar, they only waste space there.

Kattekrab (donna) wrote :

Yes - and they also have keyboard shortcuts - but I use those commands frequently, and it is much easier to make a short single click in the tool controls bar to convert objects/strokes than it is to have to do the click, hold, drag action required to access them from the menu.

There are many commands available in both places. Should we also remove New, Open, Save and Print from the commands bar because they are also in the file menu?

I use object to path and stroke to path more frequently than the clip and mask tools - so if those icons are going to be removed by default, the user coulld perhaps be given the option of putting them back in? The Clip and Mask tools are only of relevance when a clip or mask is present, whereas users need to convert shapes and text to paths to perform other actions...

Krzysztof Kosinski (tweenk) wrote :

This was never in a stable release so setting to fix released. Also dropping the absurdly high priority.

Changed in inkscape:
status: Fix Committed → Fix Released
importance: High → Low
milestone: 0.48 → none
Kattekrab (donna) wrote :

So are the buttons going to stay there or not?

Krzysztof Kosinski (tweenk) wrote :

Yes, they will stay.

Kattekrab (donna) wrote :

Yay! Thank you :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers