Changing segment into line (Shift+L) doesn't work

Bug #532905 reported by dopelover on 2010-03-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski
Nominated for 0.48.x by dopelover

Bug Description

How to reproduce:
1) Draw a curved path
2) Select some nodes
3) Try to change selected segments into straight lines (Shift+L)
This feature seems not to work anymore.

The problem concerns Inkscape revno: 9147 from Bazaar running on Ubuntu 9.10.

su_v (suv-lp) on 2010-03-05
tags: added: node-editing
su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9145 on OS X 10.5.8

works with Inkscape 0.47 r22583

Changed in inkscape:
status: New → Confirmed
tags: added: regression
su_v (suv-lp) on 2010-09-19
tags: added: shortcuts
su_v (suv-lp) wrote :

Raising importance because the feature to retract the handles of cusp nodes - apply 'Shift+c' (twice for smooth nodes) or click on 'Cusp node' (twice for smooth nodes) - was removed recently in Inkscape trunk (r9827) and the 0.48.x branch (r9685 ).

At the moment it is no longer possibly to convert curved segments to straight lines without mouse, using only keyboard shortcuts because 'Shift+L' doesn't works either in the new node tool.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
importance: Undecided → Medium
su_v (suv-lp) wrote :

Same for "Make selected segments curves": the keyboard shortcut 'Shift+U' no longer works in the node tool (0.48, 0.48+devel r9869), thus requires the mouse to click on the corresponding button on the node tool controls bar.

Krzysztof Kosinski (tweenk) wrote :

Shift+L and Shift+U now work in trunk (r9881).

Changed in inkscape:
milestone: none → 0.48.1
status: Confirmed → Fix Committed
Krzysztof Kosinski (tweenk) wrote :

Backported to 0.48 branch in rev. 9715.

jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers