Path Effect Editor dialog does not update for every second selected object

Bug #516940 reported by su_v on 2010-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Johan Engelen

Bug Description

Inkscape 0.47+devel r8975, r9020, r9045 on OS X 10.5.8
not reproduced in Inkscape 0.47 r22583

Path Effect Editor is not updated correctly when selecting (switching between) different objects with LPEs applied

Steps to reproduce:
1) create several objects with different LPEs applied (or use the attached document)
2) open Path Effect Editor
3) select tool: randomly select different individual objects with LPEs and inspect the LPE parameters

expected result: the Path Effect Editor shows all parameters of the LPE applied to the currently selected object
actual result: the dialog is not updated for every other selected object

workaround:
select an object without LPE in-between

su_v (suv-lp) wrote :
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape rev. 9070.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
tags: added: regression
Johan Engelen (johanengelen) wrote :

fixed it. very annoying bug indeed!

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.48
status: Confirmed → Fix Committed
su_v (suv-lp) wrote :

Fix confirmed with Inkscape 0.47+devel r9433 on OS X 10.5.8 :)

su_v (suv-lp) wrote :

Changing status to 'Fix Released' in accordance to <http://wiki.inkscape.org/wiki/index.php/Bug_management#Bug_status> because the bug only appeared in the development version and not in a stable release.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers