no disk exception when opening SVG file on XP/AMD64

Bug #513083 reported by stl_guy on 2010-01-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Max Gaukler

Bug Description

I made an SVG file at school on a WinXP+P4 workstation with Inkscape v0.47, saved it on a flash drive, tried to open it on my WinXP+AMD64 machine (also with Inkscape v0.47) at home and got a "No Disk" exception over and over until I killed Inkscape.exe with CTL+ALT+DEL. The file opens just fine on the P4.

Since I had the portable version at home and the "installer" version at school I tried the installer version at home -- interestingly, it was able to open the file but it was all wrong; none of the pictures imported showed up. (Yes, they were in the directory with the SVG file.) Next I tried the 7Zip version and it did the same thing as the portable version: just throw "No Disk" exceptions over and over.

Version 0.46 also has the same exception problem. (I didn't try other versions.)

Gdb didn't help since it responded to "backtrace" with "No Stack".

I would really appreciate it if you took a look at this problem. I think Inkscape is great and I would love to use it on my home machine. Thanks.

Related branches

su_v (suv-lp) on 2010-01-27
tags: added: crash win32
Changed in inkscape:
importance: Undecided → High
su_v (suv-lp) wrote :

Do you get any kind of detailed Windows crash report that gives a hint where this error happens?
Could you try if JazzyNicos's answer to the question "Windows - No Disk" <https://answers.launchpad.net/inkscape/+question/93096> helps to get closer to the underlying cause of the repeated crashes?

Alvin Penner (apenner) wrote :

does the crash occur when you first load Inkscape with no file selected, or does it occur when you click on File->Open to open the browse dialog, or does it occur when you select a specific file?

if it is caused by a specific file, could you attach it, together with the associated linked images?

could you try a right-mouse-button click on a file and select Open With...Inkscape to see if this makes a difference.

stl_guy (josealopez3) wrote :

Thank you both for your fast replies.

Alvin Penner,
The crash did not happen when I first loaded Inkscape and it did not matter which file-open method I used. It just crashed when I picked a specific file. I will make a simple test file with 1 image to reproduce what is left of the problem.

~suv,
I got the exact message posted in Question #93096. I looked at JazzyNico's response and, although the preference-file fix did not work for me, the renaming of the drives did fix part of the problem. (I have a hateful HP with like 5 flash readers.) I no longer get the exceptions but the file is not displayed correctly: the fonts are not the right ones and the pictures do not show up.

When I right-click on the empty picture boxes I see Inkscape is expecting the pictures to be in the same path as on the original machine. It might be worth changing Inkscape to use relative paths. I also noticed there are other items with paths to pictures no longer being used. Anyway, I will make the test file. Thanks again!

stl_guy (josealopez3) wrote :

I've attached a test case that shows the problem.

test_case_exported_from_P4_XP_machine.png shows the way the SVG looks on the P4 machine. The other two similarly named files show the way it looks on the AMD64 machine. When I open the SVG file on the AMD64 machine it no longer has multiple layers.

Thank you for your help!

stl_guy (josealopez3) wrote :

I was able to get past this problem by:

* renaming the flash drive letter name to be the same as on the P4 machine

* installing the missing fonts on the AMD machine

* opening the SVG file by: right-click-> open with -> browse -> InkscapePortable.exe (v 0.47)

The file did not work correctly if I opened Inkscape first and then opened using other methods.

Max Gaukler (mgmax) wrote :

Looking at the source reveals the problem:

The images are referenced and not embedded. The SVG file only contains the path to the image as "file:///D:/inkscape_test_case/Layer2.png", and because the drive letter is not the same on your other machine, inkscape cannot find the images. It would be better if you embedded them (the newer inkscape version now asks). Embedding means that the whole image content is copied into the SVG file and the original image file is no longer needed.

It seems you included images that were not embedded, but referenced. Inkscape then could not load the images because they were not at the position.

The real problem is that inkscape does not silently fail when accessing files on windows, but raises this annoying "reinsert disk" error.
We have a similar problem in #950781, although the cause there is something else.

Max Gaukler (mgmax) wrote :

the error message will disappear with the fix for Bug #950781

Changed in inkscape:
status: New → Fix Committed
jazzynico (jazzynico) on 2014-01-06
Changed in inkscape:
assignee: nobody → Max Gaukler (mgmax)
milestone: none → 0.91
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Fix backported to the 0.48.x branch, revision 10008.

Changed in inkscape:
milestone: 0.91 → 0.48.5
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions