Copying non-ASCII characters to the clipboard results in \u strings

Bug #511482 reported by Will Pittenger on 2010-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

When I have a text object with characters like 'ö', if I copy that to the clipboard and then paste into another program, I get a string starting with "\u". I should get 'ö' instead.

su_v (suv-lp) wrote :

not reproduced with Inkscape 0.47 r22583 on OS X 10.5.8 (but I have to copy the text from the 'Text' tab of the 'Text and Font…' dialog else I can't paste it externally into another application - running Inkscape under X11 on OS X).

Please add info about OS and Inkscape version.

tags: added: clipboard text

Inkscape 0.47 r22583, built Nov 21 2009 on Vista 64-bit SP2

jazzynico (jazzynico) wrote :

Not reproduced on Windows XP, Inkscape 0.47.
Text paste correctly in notepad and wordpad.

Do you have this issue with a specific program?

Changed in inkscape:
importance: Undecided → Medium

Well, I was pasting into Google Earth.

jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape 0.47.
The test pasted in Google Earth contains unicode codes instead of characters.

Workaround: copy-paste to notepad first, and then copy-paste to GE.

Changed in inkscape:
importance: Medium → Low
status: New → Confirmed
Beluga (buovjaga) wrote :

Is there any other application besides G. Earth that shows this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers