infinite loop opening attached file

Bug #511140 reported by wolfi on 2010-01-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Alvin Penner
inkscape (Debian)
Fix Released
Unknown

Bug Description

Hi,

I just tried rebuilding debian's openclipart package and noticed the attached file lead to an infinite loop repeating

** (inkscape:24622): WARNING **: helper-fns::helperfns_read_vector() Unable to convert ",0.8571428571428572,1,1" to number

** (inkscape:24622): WARNING **: helper-fns::helperfns_read_vector() Unable to convert ",0.8571428571428572,1,1" to number

** (inkscape:24622): WARNING **: helper-fns::helperfns_read_vector() Unable to convert ",0.8571428571428572,1,1" to number

on the console. The inkscape window never opens. The last lines in an strace before the loop are:

25353 stat("/usr/share/fonts/type1/gsfonts", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
25353 open("/var/cache/fontconfig/945677eb7aeaf62f1d50efc3fb3ec7d8-le64.cache-3", O_RDONLY) = 7
25353 fstat(7, {st_mode=S_IFREG|0644, st_size=34040, ...}) = 0
25353 mmap(NULL, 34040, PROT_READ, MAP_SHARED, 7, 0) = 0x7f4110eee000
25353 close(7) = 0
25353 stat("/usr/share/fonts/type1/mathml", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
25353 open("/var/cache/fontconfig/c05880de57d1f5e948fdfacc138775d9-le64.cache-3", O_RDONLY) = 7
25353 fstat(7, {st_mode=S_IFREG|0644, st_size=1472, ...}) = 0
25353 mmap(NULL, 1472, PROT_READ, MAP_SHARED, 7, 0) = 0x7f4110eed000
25353 close(7) = 0
25353 stat("/usr/share/fonts/X11/encodings/large", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
25353 open("/var/cache/fontconfig/6333f38776742d18e214673cd2c24e34-le64.cache-3", O_RDONLY) = 7
25353 fstat(7, {st_mode=S_IFREG|0644, st_size=112, ...}) = 0
25353 read(7, "\4\374\2\374\3\0\0\0p\0\0\0\0\0\0\0008\0\0\0\0\0\0\0`\0\0\0\0\0\0\0"..., 112) = 112
25353 close(7) = 0
25353 brk(0x351c000) = 0x351c000
25353 brk(0x351d000) = 0x351d000
25353 brk(0x351c000) = 0x351c000
25353 brk(0x353d000) = 0x353d000
25353 brk(0x353c000) = 0x353c000
25353 brk(0x355d000) = 0x355d000
25353 brk(0x357e000) = 0x357e000
25353 brk(0x359f000) = 0x359f000
25353 brk(0x359e000) = 0x359e000
25353 brk(0x35bf000) = 0x35bf000
25353 brk(0x35e0000) = 0x35e0000
25353 write(2, "\n** (inkscape:25353): WARNING **"..., 140) = 140
25353 write(2, "\n** (inkscape:25353): WARNING **"..., 175) = 175
25353 write(2, "\n** (inkscape:25353): WARNING **"..., 219) = 219
25353 write(2, "\n** (inkscape:25353): WARNING **"..., 174) = 174
25353 write(2, "\n** (inkscape:25353): WARNING **"..., 124) = 124
25353 write(2, "\n** (inkscape:25353): WARNING **"..., 124) = 124

I use version 0.47 from debian unstable on an amd64 laptop.
Version 0.46-2.lenny2 does render the file, so it seems to be a regression.

Thanks,

Wolfi

wolfi (wolfi-sigxcpu) wrote :
su_v (suv-lp) on 2010-01-22
tags: added: crash
su_v (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9013 on OS X 10.5.8: I didn't catch any error messages from Inkscape since it created havoc with my log file I redirect console output to (obviously *not* recommended when testing to open this file in Inkscape 0.47).

Batik 1.7 doesn't load the file at all:

org.apache.batik.bridge.BridgeException: For input string: "17,4"
 at org.apache.batik.bridge.AbstractSVGGradientElementBridge$SVGStopElementBridge.createStop(AbstractSVGGradientElementBridge.java:326)
 at org.apache.batik.bridge.AbstractSVGGradientElementBridge.extractLocalStop(AbstractSVGGradientElementBridge.java:237)
 at org.apache.batik.bridge.AbstractSVGGradientElementBridge.extractStop(AbstractSVGGradientElementBridge.java:189)
 at org.apache.batik.bridge.AbstractSVGGradientElementBridge.createPaint(AbstractSVGGradientElementBridge.java:70)
 at org.apache.batik.bridge.PaintServer.convertURIPaint(PaintServer.java:359)
 at org.apache.batik.bridge.PaintServer.convertPaint(PaintServer.java:259)
 at org.apache.batik.bridge.PaintServer.convertFillPaint(PaintServer.java:228)
 at org.apache.batik.bridge.PaintServer.convertFillAndStroke(PaintServer.java:146)
 at org.apache.batik.bridge.SVGShapeElementBridge.createShapePainter(SVGShapeElementBridge.java:117)
 at org.apache.batik.bridge.SVGDecoratedShapeElementBridge.createFillStrokePainter(SVGDecoratedShapeElementBridge.java:58)
 at org.apache.batik.bridge.SVGDecoratedShapeElementBridge.createShapePainter(SVGDecoratedShapeElementBridge.java:84)
 at org.apache.batik.bridge.SVGShapeElementBridge.buildGraphicsNode(SVGShapeElementBridge.java:91)
 at org.apache.batik.bridge.GVTBuilder.build(GVTBuilder.java:145)
 at org.apache.batik.bridge.SVGUseElementBridge.buildCompositeGraphicsNode(SVGUseElementBridge.java:216)
 at org.apache.batik.bridge.SVGUseElementBridge.createGraphicsNode(SVGUseElementBridge.java:98)
 at org.apache.batik.bridge.GVTBuilder.buildGraphicsNode(GVTBuilder.java:213)
 at org.apache.batik.bridge.GVTBuilder.buildComposite(GVTBuilder.java:171)
 at org.apache.batik.bridge.GVTBuilder.buildGraphicsNode(GVTBuilder.java:219)
 at org.apache.batik.bridge.GVTBuilder.buildComposite(GVTBuilder.java:171)
 at org.apache.batik.bridge.GVTBuilder.build(GVTBuilder.java:82)
 at org.apache.batik.swing.svg.GVTTreeBuilder.run(GVTTreeBuilder.java:96)

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
Codain (codain) wrote :

Not reproduced on Inkscape 0.48.2 on Windows 7.

Alvin Penner (apenner) wrote :

@Romain, are you by any chance running 64 bit Windows 7?

- reproduced on Windows 7 (32 bit), Inkscape 0.48.2
- reproduced on Windows XP, Inkscape devel rev 10865

multiple, unending, console error messages saying:
** (inkscape.exe:3612): WARNING **: helper-fns::helperfns_read_vector() Unable to convert ",0.8571428571428572,1,1" to number

Alvin Penner (apenner) wrote :

the original parser for table entries in the filters assumed that the entries delimiter was a blank space. This has been modified to allow the use of a comma as well.
committed to rev 10916

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2012-01-21
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
milestone: none → 0.49
Changed in inkscape (Debian):
status: Unknown → New
Changed in inkscape (Debian):
status: New → Confirmed
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.