Infinite loop when opening a file or a new file.

Bug #508649 reported by Thinker on 2010-01-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Krzysztof Kosinski

Bug Description

Inkscape would go into an infinite loop when it opens a file or a new file and start with an empty content. Steps to reproduce issue:
 1. run Inkscape in FreeBSD without any arguments.
 2. open a SVG file or a new file
 3. run into an infinite loop

It is a memory menagement issue. Inkscape::DocumentSubset::Relations::_doRemove() access content of a record, immediately, after erease the record. It is potential fault for any OS, but the code of invalid memory accessing is very close to the code to free the memory and the issue was hidden in most OS. But, for FreeBSD, its free() function clean content of free memory, so the issue is explosed.

This issue can be resolved by the patch attached.

Related branches

Thinker (thinker) wrote :
jazzynico (jazzynico) on 2010-01-17
Changed in inkscape:
importance: Undecided → High
tags: added: crash
Krzysztof Kosinski (tweenk) wrote :

Applied in r9045.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
status: New → Fix Committed
Changed in inkscape:
milestone: none → 0.48
jazzynico (jazzynico) on 2010-08-24
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers