Division won't create objects with holes

Bug #499744 reported by Steven Holte on 2009-12-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Alvin Penner

Bug Description

The division function behaves incorrectly when one of the resulting shapes should have a hole. For example, if you draw a circle inside of a square, then divide the square by the circle, you should get a square with a circular hole, and a circle. But the actual result is a square with no hole, and two circles. I've gotten this result with both 0.46 and 0.47.

su_v (suv-lp) on 2009-12-23
tags: added: boolops
Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2012-09-10
Changed in inkscape:
importance: Undecided → Medium
Alvin Penner (apenner) wrote :

fix committed to rev 12342

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2013-05-25
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
milestone: none → 0.49
su_v (suv-lp) wrote :

@Alvin - could you take a look at the attached example? There seem to be cases where this problem still happens (select one of the gray paths and the overlapping red rectangle, and apply 'Path > Division').

If you think this is unrelated to what was originally reported here, please let me know and I will file a separate report.

Alvin Penner (apenner) wrote :

thanks, it looks like it is the same problem as originally, I'll look into it.

Alvin Penner (apenner) on 2015-02-20
Changed in inkscape:
status: Fix Committed → New
su_v (suv-lp) on 2015-02-20
Changed in inkscape:
milestone: 0.91 → 0.92
status: New → Triaged
Alvin Penner (apenner) wrote :

fix committed to rev 14040

Changed in inkscape:
status: Triaged → Confirmed
status: Confirmed → Fix Committed
su_v (suv-lp) on 2015-04-03
tags: added: backport-proposed
ScislaC (scislac) wrote :

trunk r14040 backported in 0.91.x r13761

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers