Crash on quit after adding wrong links in $XDG_DATA_HOME/color/icc

Bug #494940 reported by su_v on 2009-12-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jon A. Cruz

Bug Description

follow-up to Bug #494932 “[osx] search path for color profiles doesn't include '/System/Library/ColorSync/Profiles'

adding (carelessly ;) symbolic links to the missing profiles in '/System/Library/ColorSync' in '~/.local/share/color/icc' with:

LeWitt:icc suv$ ln -s /System/Library/ColorSync/* .
LeWitt:icc suv$ ll
total 16
lrwxr-xr-x 1 suv staff 37 Dec 10 10:30 Calibrators@ -> /System/Library/ColorSync/Calibrators
lrwxr-xr-x 1 suv staff 34 Dec 10 10:30 Profiles@ -> /System/Library/ColorSync/Profiles
LeWitt:icc suv$

Inkscape fails to load any pixmap images:
**: Pixbuf theme: Cannot load pixmap file /Volumes/blue/src/Inkscape/Inkscape-0.47-1.LEOPARD+/Inkscape-047-1.app/Contents/Resources/themes/Clearlooks-Quicksilver-OSX/gtk-2.0/Scrollbars/trough-scrollbar-vert.png: Failed to open file '/Volumes/blue/src/Inkscape/Inkscape-0.47-1.LEOPARD+/Inkscape-047-1.app/Contents/Resources/themes/Clearlooks-Quicksilver-OSX/gtk-2.0/Scrollbars/trough-scrollbar-vert.png': Too many open files
(tons of related error messages snipped)

as well as this pango error:
Pango-ERROR **: Unable to open font file /Users/suv/Library/Fonts/Vera.ttf for font Bitstream Vera Sans 512, exiting

and crashes on exit (Crash report attached).

reproducible with Inkscape 0.47-1 and Inkscape r8878 on OS X 10.5.8

su_v (suv-lp) wrote :

crash report with Inkscape 0.47-1 from sf.net

su_v (suv-lp) wrote :

similar result with local build (bundled as app) from bzr (r8878) using the tango/hicolor gtk-icon-theme (from KK) and a custom gtk-theme (default and 'mist' engine).

su_v (suv-lp) wrote :

console log from crash with Inkscape r8878 on OS X 10.5.8

description: updated
su_v (suv-lp) wrote :

Contents of the link that lets Inkscape crash:

LeWitt:~ suv$ ls -al /System/Library/ColorSync/Calibrators/
total 0
drwxr-xr-x 3 root wheel 102 Nov 19 06:03 ./
drwxr-xr-x 4 root wheel 136 Nov 7 2008 ../
drwxr-xr-x 3 root wheel 102 Nov 19 06:03 Display Calibrator.app/
LeWitt:~ suv$ ls -alR /System/Library/ColorSync/Calibrators/| wc -l
    1729
LeWitt:~ suv$ du -sch /System/Library/ColorSync/Calibrators/
2.8M /System/Library/ColorSync/Calibrators/
2.8M total
LeWitt:~ suv$

removing '~/.local/share/color/icc/Calibrators' restores normal behavior of Inkscape.

Jon A. Cruz (jon-joncruz) wrote :

Appears to have been partially due to not closing directories, and in two different sections of code doing similar-yet-slightly-different directory walking.

Changed in inkscape:
assignee: nobody → Jon A. Cruz (jon-joncruz)
importance: Undecided → Medium
status: New → Confirmed
status: Confirmed → In Progress
Changed in inkscape:
status: In Progress → Fix Committed
su_v (suv-lp) wrote :

 trunk: r9834
0.48.x: r9689

Changed in inkscape:
milestone: none → 0.48.1
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers