Inkscape: A Vector Drawing Tool

EPS Level 3 export Rasterized

Reported by ToddB on 2009-12-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

In Inkscape version 0.47 we now have a choice of level 2 or level 3 EPS export (the previous version was understood to be level 3 only). Now, when specifying level 3 output any file with regular (fully opaque, alpha 255) gradients seems to become rasterized (easily noticeable since the file size is way larger than it is supposed to be). When I export I have "Rasterize Filter Effects" set to off - but this is irrelevant anyway since a gradient is not an effect. I have tried to export different SVG files as EPS 3 and get the same result. I am attaching a sample Inkscape SVG file. Thanks.

Related branches

ToddB (sartre98) wrote :
ToddB (sartre98) wrote :
ToddB (sartre98) wrote :
~suv (suv-lp) on 2009-12-02
tags: added: eps exporting
~suv (suv-lp) wrote :

reproduced with Inkscape 0.46 and Inkscape 0.47 on OS X 10.5.8
looking at the EPS files however it seems as if the labels for 'Restrict to PS level' in the export dialog have been mixed up:

EPS exported as 'PostScript level 2':

%!PS-Adobe-3.0 EPSF-3.0
%%Creator: cairo 1.8.8 (http://cairographics.org)
%%CreationDate: Wed Dec 2 22:47:55 2009
%%Pages: 1
%%BoundingBox: 0 0 177 178
%%DocumentData: Clean7Bit
%%LanguageLevel: 3
%%EndComments
%%BeginProlog

EPS exported as 'PostScript level 3':

%!PS-Adobe-3.0 EPSF-3.0
%%Creator: cairo 1.8.8 (http://cairographics.org)
%%CreationDate: Wed Dec 2 22:48:13 2009
%%Pages: 1
%%BoundingBox: 0 0 177 178
%%DocumentData: Clean7Bit
%%LanguageLevel: 2
%%EndComments
%%BeginProlog

~suv (suv-lp) on 2010-03-12
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
~suv (suv-lp) wrote :

Same issue (Language level 3 as export option creates level 2 files, Language level 2 as export option creates level 3 files) with bitmaps which have a transparent background (even worse when they are clipped, possibly due to bug in cairo 1.8.x):

Bug #585286 “Exporting SVG with transparent embedded PNG causes excessive blurriness”:
<https://bugs.launchpad.net/inkscape/+bug/585286>

~suv (suv-lp) wrote :

Patch proposed in
Bug #698340 in Inkscape: “PS Level Restriction reversed”
<https://bugs.launchpad.net/inkscape/+bug/698340>

jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 10000.

Changed in inkscape:
milestone: none → 0.49
status: Confirmed → Fix Committed
~suv (suv-lp) wrote :

Also committed in the 0.48.x branch, revision 9754.

Changed in inkscape:
milestone: 0.49 → 0.48.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers