Tweak Tool : Opacity doesn't change in Paint/Jitter modes

Bug #490225 reported by Yann Papouin on 2009-11-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

In 0.47, Opacity is not affected by the tweak tool even when selected in the toolbar.
About this, it's said "opacity of the object", it's really opacity or it is the alpha value of the color ?

su_v (suv-lp) on 2009-11-30
tags: added: tweak
su_v (suv-lp) wrote :

possibly related to
Bug #274338 “Tweak tool color modes are one directional”:
<https://bugs.launchpad.net/inkscape/+bug/274338>
which is marked as 'Fixed released' but still has reproduce-able issues.

tags: added: color
jazzynico (jazzynico) wrote :

Confirmed on Windows XP, Inkscape trunk revision 10130.

Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
jazzynico (jazzynico) wrote :

Patch attached.
Apparently, the modified parameter is used by the tweak tool only.

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
milestone: none → 0.49
status: Triaged → In Progress
jazzynico (jazzynico) wrote :
jazzynico (jazzynico) wrote :

> it's really opacity or it is the alpha value of the color ?

Yes, it's really opacity!

jazzynico (jazzynico) wrote :

Fix committed in the trunk, revision 10139.

Changed in inkscape:
status: In Progress → Fix Committed
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Backported to the 0.48.x branch, revision 9789.

Changed in inkscape:
milestone: 0.49 → 0.48.2
tags: removed: backport-proposed
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers