EPS export with inactive layers is blurred

Bug #489713 reported by oksmith on 2009-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

This bug is related to the other Cairo bugs but should be simple to fix.

This was tested with Inkscape 0.47 r22583, built Nov 24 2009 on OSX Snow Leopard.

If a drawing has an INACTIVE layer and the INACTIVE layer has an opacity less than 100%, the EPS result is rasterized.

See the attached file and try the following:

With the opacity of the INACTIVE layer set less than 100%, save the file as an EPS. Zoom in and observe the result. It is rasterized.

With the opacity of the INACTIVE layer set to 100%, save the file as an EPS. Zoom in and observe the result. It is not rasterized.

I can't see any reason why the opacity of an INACTIVE layer should affect the results. This should be easy to fix.

As a result of this bug, I cannot product quality EPS with many of my existing drawings. :-(

And finally: I love Inkscape! :-)

oksmith

su_v (suv-lp) wrote :

reproduced with Inkscape 0.46+devel r22598 on OS X 10.5.8,
using Apple's Preview.app to view the EPS output (conversion to PDF on-the-fly)
and confirmed with gv 3.6.7 (using gs 8.70)

Un-checking the export option 'rasterize filter effects' has no effect on the EPS output.
PDF export of the same file however doesn't expose this bug.

tags: added: eps exporting
Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

this is most likely a duplicate of or related to
Bug #427226 “EPS export with transparent layers is blurred, and imprecise clipping in PDF export”:
<https://bugs.launchpad.net/inkscape/+bug/427226>

oksmith (oksmith) wrote :

This bug may be a duplicate. Using the example it is easily observed.

There should be no reason for an inactive layer of a drawing to affect the output.

Thanks.

Beluga (buovjaga) wrote :

I can't seem to reproduce the problem. Please re-test.

Arch Linux 64-bit, KDE Plasma 5
Inkscape 0.91 r13725

jazzynico (jazzynico) wrote :

Reproduced on Windows XP, Inkscape 0.48.1.
Not reproduced with 0.48.2 and more recent versions.

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.48.1
status: Confirmed → Fix Released
milestone: 0.48.1 → 0.48.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers