Win32 installer very inefficient in generating its uninstall log

Bug #488454 reported by Don Hess on 2009-11-25
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Eduard Braun

Bug Description

I'm silently installing the Inkscape-0.47-3.exe on Windows XP SP2 and SP3. The installer will install fine but then look likes it is hanging. It takes up 100% of what ever CPU it is running on, so 1 core of a 2 core CPU, etc. This occurs for about 3-5 minutes after the Inkscape files are installed. There isn't any hard drive activity. Eventually the installer closes and everything is fine. This also happens when I run it locally on the workstation. Previous versions of Inkscape do not experience this problem. The switches I am using are:
/S /D="c:\program files\Inkscape" /GTK=OFF /ALLUSER=ON /SVGEDITOR=ON /SHORTCUTS=ON /DESKTOP=OFF /TUTORIALS=ON /EXAMPLES=ON"

thanks,

su_v (suv-lp) on 2009-11-25
tags: added: packaging win32
Don Hess (don-hess) wrote :

I've look at it some more and the core does max but eventually the installer looks like it is proceeding and then the hard drive light comes on. So maybe it really does take 3 minutes to do an install. This seems like along time to copy 200MB. The computer I'm on is a Dell D830 laptop. Core2 Duo, 2GB RAM, Win XP SP2.

Chris Morgan (chris.morgan) wrote :

I can't think of or find any cause in the Installer source code for this behaviour; you're sure about there being no hard drive activity? It may be the writing of the installation log for the uninstaller.

I've had the same problem -- both in background install mode, and foreground install mode it actually seems that this might be "normal". After force quitting the background installer after ~20 minutes of CPU time were used, I ran it in the normal double-click mode. After getting through most of the way through the install, it pegged my CPU. The progress says "Search In C:\Program Files\Inkscape\etc\fonts\conf.avail". I'm guessing that this is just some sort of font scan that eats up absurd amounts of CPU time.

William Blunn (bill+launchpad) wrote :

I have just experienced this problem also.

The installer says "Search in:" followed the name of a directory within the Inkscape install.

It switches from directory to directory, taking about a minute or two on each one.

Process Explorer says it is eating 50% of available CPU (this is in a Core Duo lapttop).

It seems to be doing something unbelievably labourious and unnecessary with each directly.

The clue must be in the string "Search in:" which must appear in the source somewhere. Whatever is putting up "Search in:" has got to be the culprit.

Chris Morgan (chris.morgan) wrote :

The "Search in: " problem is mainly to do with the way the whole installer architecture (in particular the uninstaller) has been designed (it's particularly a problem if you've got languages selected, but not just then). I'm not sure who initially designed it, but it definitely does leave some things to be desired. If I had lots (and lots) of spare time, I'd be rewriting the installer to use a pre-processor to list all files individually and avoid this need to do lots of searching, directory changing, file listing etc. every time it runs, but rather just at compile time. That'd make it easier to verify some things too.

summary: - Silent Windows install of 0.47 maxes out CPU for 3-5min
+ Win32 installer very inefficient in generating its uninstall log
Owen Dunn (osd1000) wrote :

Watching the file activity with filemon, it seems to spend vast quantities of time reading from %TEMP%\nsbA2.tmp\exclude.tmp _one byte at a time_.

dkg (dkg0) wrote :

This lengthy hang seems to still be happening on windows 7 with installer version 0.48.1

Dan Cecile (dancecile) wrote :

Also on Windows 7, with Inkscape-0.48.2-1-win32.exe, %TEMP%\nsr9E25.tmp\exclude.tmp is being read one byte at a time (as seen from Proccess Monitor), and 100% of one CPU is being used. Installation time is over half an hour.

Jesse B. Crawford (jeanluc-4) wrote :

0.48.3.1-win32.exe installer has been running for 25 minutes now, using 100% of CPU. It is generating the install log, extremely slowly. Is there any progress/any one looking in to this bug?

Simón A. Ruiz (simon.a.ruiz) wrote :

I have also seen some pretty insanely long install times under Windows XP. Over a half an hour is not uncommon...

No issues installing on Ubuntu.

jazzynico (jazzynico) wrote :

Note that a new MSI installer is currently under envelopment.

Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
jazzynico (jazzynico) wrote :

...under development.

Eduard Braun (eduard-braun2) wrote :

This should be fixed with the latest batch of NSIS installer improvements, specifically r15114 [1].

Feel free to test the latest pre-release package [2] and report back if you're still experiencing problems.

[1] http://bazaar.launchpad.net/~inkscape.dev/inkscape/0.92.x/revision/15114
[2] https://download.tuxfamily.org/inkscape/win64/Inkscape-0.92pre2-x64-1.exe

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
status: Triaged → Fix Committed
jazzynico (jazzynico) on 2016-10-19
Changed in inkscape:
milestone: none → 0.92
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers