<symbol/use> of imported SVG not exportable to EPS/PDF

Bug #485846 reported by Dirk Speidel on 2009-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I have exported a small graphic (a user defined symbol) from Corel Designer 12 into SVG.
If I open the SVG file it looks fine, but the export into eps with Inkscape 0.47prev4 the eps does not work.
GSView throw the error below:
...
Unrecoverable error: configurationerror in setpagedevice
Operand stack:
    false --nostringval--
Failed to open device or install ViewerPreProcess hook: returns -26

The export with Inkscape 0.46 works fine.

Attached you will find an example.

Dirk Speidel (dirk-speidel) wrote :
su_v (suv-lp) on 2009-11-20
tags: added: eps import-export svg
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.46+devel r22575 on OS X 10.5.8:
the exported EPS (or PDF) files appear empty.

The SVG drawing consists only of clones of symbols and glyphs in the <defs> section. This seems similar to bug #436962 “pdf not rendered correctly” where directly used 'svg:symbol' don't get exported to Cairo PDF either.

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) on 2011-01-20
tags: added: exporting pdf
removed: import-export svg
su_v (suv-lp) on 2011-01-21
summary: - imported svg not exportable to eps
+ <symbol/use> of imported SVG not exportable to EPS/PDF
Changed in inkscape:
importance: Undecided → Medium
su_v (suv-lp) wrote :

Same file imported into a new document with larger page size shows that the instantiated symbols are missing at the rendered position (displaced?) and the original definitions of the symbols are exported despite of not being referenced by a <use> element.

su_v (suv-lp) wrote :

exported to PDF with Inkscape 0.48+devel r10009 (cairo 1.10.2) on OS X 10.5.8

su_v (suv-lp) wrote :

No longer reproduced with r10197 (which includes the patch for related bug #705345)

jazzynico (jazzynico) wrote :

Confirmed fixed in the trunk (tested on Windows XP, revision 10342).

Changed in inkscape:
milestone: none → 0.49
status: Confirmed → Fix Committed
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Backported to the branch, revision 9810.

Changed in inkscape:
milestone: 0.49 → 0.48.2
tags: removed: backport-proposed
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers